Results 1 to 8 of 8
  1. #1
    Newbie
    Join Date
    April 21st, 2008
    Posts
    7
    Need assistance with index page
    Friends,
    I could use some assistance with my index page. I need to add a width attribute to my image

    "[WM-ImagePath: image_link] width=50"

    and I would like to use one of my images for a link to the detail page of the product. What tag do I use?

    "<a href="[WM-AccessLink: id]" target="_self" class="txtButton"><img src="moreinfo.gif" align=absMiddle border=0></a>"

    Thanks for your help!!! The full code is below.



    [WM-Record]

    <table border="0" width="475">
    <tr>
    <td rowspan="2" align="left" valign="middle" width="65">[WM-ImagePath: image_link] width=50 </td>

    <td colspan="2" align="left"> <strong>[WM-Field: title]</strong></a></td>
    </tr>
    <tr>

    <td align="left"><font class="text"><b>Our Price: </b></font><b><font class="pricecolor">&nbsp;[WM-Field: price noLink raw]</font></b></td>

    <td align="right" width="256" valign="middle">&nbsp;&nbsp;<a href="[WM-AccessLink: id]" target="_self" class="txtButton"><img src="moreinfo.gif" align=absMiddle border=0></a></form>
    </td>

    </tr>
    </table>
    <hr color="#000000" size="1" />

    [/WM-Record]

  2. #2
    ABW Veteran Mr. Sal's Avatar
    Join Date
    January 18th, 2005
    Posts
    6,795
    Quote Originally Posted by rbass
    Friends,
    I could use some assistance with my index page. I need to add a width attribute to my image

    "[WM-ImagePath: image_link] width=50"
    Try this:

    [WM-ImagePath: Thumbnail width=50 height=50]


    and I would like to use one of my images for a link to the detail page of the product. What tag do I use?
    [WM-Record cols=3 width=500] [WM-ImagePath: Thumbnail width=100 height=100]
    [WM-Field: Description raw nolink]
    [WM-Field: Name]
    [/WM-Record]


    You can also check out this thread for more help with some of the Webmerge code: http://forum.abestweb.com/showthread...ight=templates
    Last edited by Mr. Sal; August 15th, 2008 at 11:30 AM.

  3. #3
    Newbie
    Join Date
    April 21st, 2008
    Posts
    7
    Mr. Sal,
    Thank you! The width attbribute worked!!

    I still could use some assistance allowing one of my images to be used as a link. (This is a "more info" button that is not in the database.) Below is the code. What link do I use?

    Thanks!

    Randy


    <td align="right" width="256" valign="middle">&nbsp;&nbsp;

    <a href="[WM-AccessLink: id]"><img src="moreinfo.gif" align=absMiddle border=0></a>

    </td>

  4. #4
    ABW Veteran Mr. Sal's Avatar
    Join Date
    January 18th, 2005
    Posts
    6,795
    Quote Originally Posted by rbass
    Mr. Sal,
    Thank you! The width attbribute worked!!

    I still could use some assistance allowing one of my images to be used as a link. (This is a "more info" button that is not in the database.) Below is the code. What link do I use?

    Thanks!

    Randy


    <td align="right" width="256" valign="middle">&nbsp;&nbsp;

    <a href="[WM-AccessLink: id]"><img src="moreinfo.gif" align=absMiddle border=0></a>

    </td>
    Randy,

    You may have to use something like this code in order to get the moreinfo part:

    [WM-Field: Description raw]... <!--webbot bot="HTMLMarkup" startspan --><a href="[WM-Field: Link raw]">More Info.</a><!--webbot bot="HTMLMarkup" endspan -->
    If that don't work, just check on the link I put above and try to get the free templates I made a couple of years ago.

    If you download those free templates, you will be able to see how some of those code work.

  5. #5
    Newbie
    Join Date
    April 21st, 2008
    Posts
    7
    Sal,
    I am trying to link to the detail page, not to a link supplied in the database. I am also using a outside image which is not in the database as a link to the detail page.

    I appreciate your help!!!

    Randy

  6. #6
    ABW Veteran Mr. Sal's Avatar
    Join Date
    January 18th, 2005
    Posts
    6,795
    Quote Originally Posted by rbass
    Sal,
    I am trying to link to the detail page, not to a link supplied in the database. I am also using a outside image which is not in the database as a link to the detail page.

    I appreciate your help!!!

    Randy
    Randy,

    If you already have WebMerge, you can see how to do what you want to do with the "images to be used as a link" from the help page: WebMergeHelp.html, that comes with WebMerge.
    --------------
    4W WebMerge Tag Reference

    WM-ImagePath

    Syntax [WM-ImagePath: fieldName]

    [WM-ImagePath: fieldName nolink]

    Examples [WM-ImagePath: ImageFile]

    [WM-ImagePath: ImageFile width="100" height="100]

    Description The [WM-ImagePath] tag is replaced by an <img> tag in the generated page, using the file path in the data of the field specified in fieldName as the src attribute.

    In the example shown above, if your database includes a field named "ImageFile", you can include the path to an image file in that field. Using this tag, WebMerge will build an <img> tag, using the data in the database field as its source, like this:

    <img src="images/mypicture.jpg">

    When used in an index template, by default WebMerge generates all tags as links to the corresponding detail page. The optional nolink attribute is used in index pages to tell WebMerge to write the <img> tag without linking it to that detail page. If used in an detail page template, the nolink attribute is ignored.

    Adding Image Attributes

    HTML supports a variety of attributes for images, such as specifying the width or height of an image, its border size, and more. You can include these in your WM-ImagePath tag. Anything between the end of the specified file and the closing bracket ("]") is assumed to be your own HTML attributes, and are copied into the generated IMG tag for you.

    For instance, the HTML WebMerge would generate from the last example above would look like:

    <img src="image/mypicture.jpg" width="100" height="100">

    Introduced in version 1.8.
    Verison 2.4 introduced support for additional image attributes to be included with the generated HTML.
    --------------
    You can find more info here: http://www.fourthworld.com/products/...e/support.html

  7. #7
    Newbie
    Join Date
    April 21st, 2008
    Posts
    7
    Mr. Sal,
    Thanks for your help! I am using an image on my server in my images folder, not in the database. I could not get the tags to work.

    Can you please give me another method to use so that I can use an 'outside' image as a link?

    Thanks!

    Randy

  8. #8
    ABW Veteran Mr. Sal's Avatar
    Join Date
    January 18th, 2005
    Posts
    6,795
    I am using an image on my server in my images folder, not in the database. I could not get the tags to work.
    I went tru all this problems many year ago when I started using WebMerge.

    Are you using FrontPage?

    Way back then I had to use this code:

    <!--webbot bot="HTMLMarkup" startspan -->[WM-Field: TAGs]<!--webbot bot="HTMLMarkup" endspan -->

    between some of the WebMerge tags, in order to get my images to work the way I wanted.

    So try to use this code: <!--webbot bot="HTMLMarkup" startspan --> PUT your WM image TAG HERE <!--webbot bot="HTMLMarkup" endspan -->

    And see if it works for you.

  9. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. How can I search, link index page to detail page?
    By rbass in forum WebMerge (Fourthworld.com)
    Replies: 2
    Last Post: August 15th, 2008, 12:33 PM
  2. How to show index numbers on index page?
    By sinpeople in forum WebMerge (Fourthworld.com)
    Replies: 0
    Last Post: June 24th, 2007, 12:06 AM
  3. Making an index page of index pages
    By Pierre (aka Terdef) in forum WebMerge (Fourthworld.com)
    Replies: 0
    Last Post: June 30th, 2005, 05:24 AM
  4. my index page
    By henrylair in forum WebMerge (Fourthworld.com)
    Replies: 6
    Last Post: October 24th, 2004, 12:42 PM
  5. how do I link from a detail page back up to a category/index page?
    By pw3909 in forum WebMerge (Fourthworld.com)
    Replies: 3
    Last Post: May 4th, 2004, 06:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •