Results 1 to 9 of 9
  1. #1
    Newbie
    Join Date
    December 13th, 2008
    Posts
    13
    [WM-FieldInclude: ] Problems
    Hi,

    Was wondering if anyone had trouble with the WM-FieldInclude tag. I was using it with some success but in my latest build I started getting an error. I finally figured out that when I removed this tag from my template, everything worked fine (except for the missing data I wanted to include).

    When the field in included in the template, I get this error:

    Error processing record 194:
    (WM-FieldInclude failed - file not found:
    /Users/edkim/Documents/affiiate sites/eco inn/site/)
    Error processing record 194: Can't open included file:
    /Users/edkim/Documents/affiiate sites/eco inn/site/
    (error reading file)

    Does anyone have any suggestions. I imagine I need to supply some more info on the makeup of my files. Let me know what you need.

    Thanks

  2. #2
    Affiliate Manager
    Join Date
    January 18th, 2005
    Location
    Los Angeles, California
    Posts
    1,913
    Is the path shown where the file actually is?

    That's where WebMerge thinks it is, based on the path passed to it in the WM-FieldInclude tag.

    Is the path in the specified field a full path or relative? Remember that any partial path should be relative to the generated page.
    Richard Gaskin
    Developer of WebMerge: Publish any data feed on any site
    http://www.fourthworld.com

  3. #3
    Newbie
    Join Date
    December 13th, 2008
    Posts
    13
    Realtive paths
    Hi,

    The path in the error message is actually the location of the generated site, not the html I want to embed.

    /Users/edkim/Documents/affiiate sites/eco inn/site/

    I used this code to say where the ebedded html should be relative to the site. Essentially 'up' one folder, then 'down' into the folder 'html-snippets' where a file Maine.html is.

    ../html-snippets/Maine.html

    I also tried to use an absolute path
    /Users/edkim/Documents/affiiate sites/eco inn/html-snippets/Maine.html

    this one really did not work.

  4. #4
    Newbie
    Join Date
    December 13th, 2008
    Posts
    13
    Other info
    Other pieces of info that might help.

    The the error message says there was a problem at record 194 but there are only 193 records.

    Also note that this worked for me last week and I really did not change much since then.

    Thanks if advance for your help.

  5. #5
    Affiliate Manager
    Join Date
    January 18th, 2005
    Location
    Los Angeles, California
    Posts
    1,913
    If WebMerge thinks there are more records in the file than there are, double-check the delimiters to make sure they're appropriate for the format of the source file you're using.

    Also, I'm assuming from the path name that you're using OS X, is that correct? If so, you may not need the first two segments of your path (assuming "edkim" is the user account you're running under). So this may work:

    /Documents/affiiate sites/eco inn/html-snippets/Maine.html

    But double-check the delimiters first. That'll affect a lot of things, so we'll want to see that those are in order before trying other options.
    Richard Gaskin
    Developer of WebMerge: Publish any data feed on any site
    http://www.fourthworld.com

  6. #6
    Newbie
    Join Date
    December 13th, 2008
    Posts
    13
    It works!
    Thanks for the advice. I went into the spreadsheet and deleted a bunch of rows at bottom of the sheet. They looked blank but a stray character must have been typed in. After deleting the lines everything worked perfectly!

    Thanks again. Your support rocks!

  7. #7
    Affiliate Manager
    Join Date
    January 18th, 2005
    Location
    Los Angeles, California
    Posts
    1,913
    Glad to hear that worked out.
    And thanks for the kind words.

    I forgot to ask you: are you using v2.4 or v2.5?

    If you're not using v2.5 I would recommend you give it a try, since we're moving toward release on that soon and your input on it would be appreciated:
    http://www.fourthworld.com/products/.../download.html

    Thanks!
    Richard Gaskin
    Developer of WebMerge: Publish any data feed on any site
    http://www.fourthworld.com

  8. #8
    Newbie
    Join Date
    December 13th, 2008
    Posts
    13
    Thanks Richard.

    I'm using version 2.5b4

  9. #9
    Affiliate Manager
    Join Date
    January 18th, 2005
    Location
    Los Angeles, California
    Posts
    1,913
    Thanks for the confirmation. Looks like we're very close to a go with v2.5. I have another couple issues to check out, but so far looking good. I appreciate your help testing this new version.
    Richard Gaskin
    Developer of WebMerge: Publish any data feed on any site
    http://www.fourthworld.com

  10. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Getting WM-FieldInclude to change for different index pages
    By jaehunkim in forum WebMerge (Fourthworld.com)
    Replies: 1
    Last Post: March 3rd, 2010, 09:43 AM
  2. More problems
    By Howard Gottlieb in forum Commission Junction - CJ
    Replies: 6
    Last Post: July 13th, 2007, 02:53 PM
  3. WM-FieldInclude
    By djones in forum WebMerge (Fourthworld.com)
    Replies: 2
    Last Post: May 22nd, 2007, 02:45 PM
  4. WM - Include or WM - FIELDINCLUDE
    By Rodski in forum WebMerge (Fourthworld.com)
    Replies: 2
    Last Post: October 11th, 2006, 12:21 PM
  5. More CJ problems?
    By UncleScooter in forum Commission Junction - CJ
    Replies: 31
    Last Post: May 3rd, 2005, 06:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •