Results 1 to 17 of 17
  1. #1
    Member onecrazymom's Avatar
    Join Date
    July 11th, 2007
    Location
    Portland
    Posts
    132
    Question Puzzling Issue with Word Press
    Hello, all... I'm having a strange issue with WP that I hope someone here can help me with.

    I've used WP on a few of my sites for over 3 years, with no problems. Today, I picked up two older projects to "dust them off" and update 'em. Both of them have the same issue (both running latest version of WP, each using a different theme). On posts that I've used the "more" tag, clicking the "read more" link results in one of two things: it will either 1) simply refresh my home page or 2) redirect to a random link that I used in my post (iow, if I linked to twitter.com, clicking the "read more" link after the post's intro would result in being redirected to twitter.com.

    The facts:

    * Both are using WP 2.8.1 (as are most of my other WP sites)
    * They are using different themes (one is a premium theme, one is a free theme)
    * They are both hosted on the Go Daddy (while a majority of my others are hosted with Host Gator)
    * My other Go Daddy-hosted site is also a WP site, and the "more" tags/links are working fine on that one (this one that's working is using the same premium theme that the above-mentioned non-working one is using).

    Anyone ever experience anything like this? Or have any suggestions or solutions?

  2. #2
    ABW Ambassador ladidah's Avatar
    Join Date
    October 15th, 2007
    Location
    MA
    Posts
    1,888
    Whenever I see something going wrong with WP it is usually the plugins. Perhaps some plugins need to be updated, reactivated or deactivated (Do you have "Limit Post" plugin or "Advanced Category" plugin?)

    I had to de-activate each plugin to find the right culprit. Many times it was the "Advanced Category" plugin that was the problem. I have since then deactivated that plugin permanently.

    I would check the WP forums for more answers. Lots of experts there on WP.

  3. #3
    Beachy Bill's Avatar
    Join Date
    November 20th, 2005
    Posts
    8,266
    Unfortunately, there have been reports of (strange?) problems with GoDaddy hosting (not meaning to imply that is the cause your current problem). They are good for domains (except for the constant upsell screens), but not so hot for hosting.

    I still have a few of my domains with them but would NOT use them for hosting a site that I depended on for income. YMMV
    Bill / Marketing Blog @ 12PM - Current project: Resurrecting my "baby" at South Baltimore..
    Cute Personal Checks and Business Checks
    If you are too busy to laugh you are too busy.

  4. #4
    Newbie DressesByDaisy's Avatar
    Join Date
    February 10th, 2009
    Posts
    49
    That is handled specifically by the theme files. Try to find where you got the themes from and email them to see if it is an issue with upgrading the theme.

    Hope this helps

  5. #5
    Member onecrazymom's Avatar
    Join Date
    July 11th, 2007
    Location
    Portland
    Posts
    132
    Quote Originally Posted by ladidah
    Whenever I see something going wrong with WP it is usually the plugins. Perhaps some plugins need to be updated, reactivated or deactivated (Do you have "Limit Post" plugin or "Advanced Category" plugin?)

    I had to de-activate each plugin to find the right culprit. Many times it was the "Advanced Category" plugin that was the problem. I have since then deactivated that plugin permanently.

    I would check the WP forums for more answers. Lots of experts there on WP.
    These two sites just have one plugin in common, which is a plugin I use on all of my sites.... :\

  6. #6
    Newbie DressesByDaisy's Avatar
    Join Date
    February 10th, 2009
    Posts
    49
    Can you temporarily change the theme to the 'default theme' and see if it still exhibits that behavior?

  7. #7
    Member onecrazymom's Avatar
    Join Date
    July 11th, 2007
    Location
    Portland
    Posts
    132
    Quote Originally Posted by Bill
    Unfortunately, there have been reports of (strange?) problems with GoDaddy hosting (not meaning to imply that is the cause your current problem). They are good for domains (except for the constant upsell screens), but not so hot for hosting.

    I still have a few of my domains with them but would NOT use them for hosting a site that I depended on for income. YMMV
    Beachy, my initial intuition made me think it was a Godaddy issue, since these are two of just three that I host on Godaddy. My sites that I host elsewhere have no problems. Could a hosting company affect how a link acts, though...?

  8. #8
    Member onecrazymom's Avatar
    Join Date
    July 11th, 2007
    Location
    Portland
    Posts
    132
    Quote Originally Posted by DressesByDaisy
    That is handled specifically by the theme files. Try to find where you got the themes from and email them to see if it is an issue with upgrading the theme.

    Hope this helps
    Daisy, this was another thought of mine, but as I said before... one of the "wonky" sites is using the same premium theme that I use on another site.

    I have 3 sites on Godaddy hosting. We'll call them A B and C. A and B are both wonky. C is fine. B (wonky) and C (not wonky) use the same premium theme.

  9. #9
    Member onecrazymom's Avatar
    Join Date
    July 11th, 2007
    Location
    Portland
    Posts
    132
    Quote Originally Posted by DressesByDaisy
    Can you temporarily change the theme to the 'default theme' and see if it still exhibits that behavior?
    I just did this, at your suggestion, and yes, it's still acting the same.

  10. #10
    Newbie DressesByDaisy's Avatar
    Join Date
    February 10th, 2009
    Posts
    49
    Quote Originally Posted by onecrazymom
    I just did this, at your suggestion, and yes, it's still acting the same.

    Okay that rules out the theme.
    Let's dig deeper....

    Does it happen if you create a new post with the more tag (it can be a draft that you just preview) ?

  11. #11
    Member onecrazymom's Avatar
    Join Date
    July 11th, 2007
    Location
    Portland
    Posts
    132
    Quote Originally Posted by DressesByDaisy
    Okay that rules out the theme.
    Let's dig deeper....

    Does it happen if you create a new post with the more tag (it can be a draft that you just preview) ?
    Well, it can't be a draft, because the issue isn't with viewing the post's page. Maybe I should have mentioned that before... on the posts that use the more tag, the "read more" link is wonky, BUT I can read the whole post by clicking the post's title.

    So.. I just created a simple post and published it (using the WP default theme). The same thing happened. I can read the beginning of the post, but when I click "read the rest of this entry," the home page just refreshes. I can only read the whole post by clicking on the entry's title.

  12. #12
    Newbie DressesByDaisy's Avatar
    Join Date
    February 10th, 2009
    Posts
    49
    Duh, my bad I'm always scared of publishing an article before it's proper.

    Okay, now if you go into your post and look at the HTML in the editor, do you see the
    <!--more-->
    tag or are you using a customized more tag that looks different?

  13. #13
    Member onecrazymom's Avatar
    Join Date
    July 11th, 2007
    Location
    Portland
    Posts
    132
    Quote Originally Posted by DressesByDaisy
    Duh, my bad I'm always scared of publishing an article before it's proper.

    Okay, now if you go into your post and look at the HTML in the editor, do you see the
    <!--more-->
    tag or are you using a customized more tag that looks different?
    It's <!--more-->.

  14. #14
    Newbie DressesByDaisy's Avatar
    Join Date
    February 10th, 2009
    Posts
    49
    Quote Originally Posted by onecrazymom
    It's <!--more-->.
    Okay, that's all the simple troubleshooting

    Next, without seeing your site, I can recommend

    Try it in both Firefox and IE to make sure it isn't a browser setting you have.

    Try it from a different PC to make sure that it isn't only happening on your PC.

    Then, I would start trying to trace the code to find out what exactly was the link (right click the more link and choose 'COPY LINK LOCATION') and determine why it was being set to that.

    Sorry I couldn't help but at least you've got the basic troubleshooting out of the way.

  15. #15
    Member onecrazymom's Avatar
    Join Date
    July 11th, 2007
    Location
    Portland
    Posts
    132
    Quote Originally Posted by DressesByDaisy
    Okay, that's all the simple troubleshooting

    Next, without seeing your site, I can recommend

    Try it in both Firefox and IE to make sure it isn't a browser setting you have.

    Try it from a different PC to make sure that it isn't only happening on your PC.

    Then, I would start trying to trace the code to find out what exactly was the link (right click the more link and choose 'COPY LINK LOCATION') and determine why it was being set to that.

    Sorry I couldn't help but at least you've got the basic troubleshooting out of the way.
    I tried to email you via ABW so that I could give you the URL, but got a msg saying you don't accept email via ABW. :\

    I tried in FF and IE earlier today. Have tried it on my 2 laptops, hubby's 2, and my kids'.

    Thanks for all the help.

  16. #16
    Newbie DressesByDaisy's Avatar
    Join Date
    February 10th, 2009
    Posts
    49
    It does sound like the <!--more--> tag is getting stuck inside another tag, specifically an anchor tag <a> . View the HTML and see if there are any tags that aren't properly closed. Then view the blog and choose VIEW SOURCE CODE in your browser and see if that has any tags that aren't properly closed around the link for seeing more of the article.

    It's just weird that it would happen for that new post you did, it's quite the mystery

  17. #17
    SEO: A Specialty - Web Design: Slow or outsourced andbeyond's Avatar
    Join Date
    June 18th, 2006
    Location
    The Call is coming from Inside the House!
    Posts
    1,332
    Are all the other plugins up to date?

    Are you using post footer or yet another related post plugin or something like that? A plugin that modifies what happens in each post.

    YARPP and sociable sometimes fight on my blogs.

  18. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Power-up your commissions and get a FREE Word Press theme ...
    By Andy Rodriguez in forum Andy Rodriguez Consulting
    Replies: 3
    Last Post: September 23rd, 2011, 07:50 AM
  2. Datafeed Word press Plug-in?
    By Chuck Hamrick in forum Programming / Datafeeds / Tools
    Replies: 13
    Last Post: August 15th, 2010, 10:53 PM
  3. Installing Golden Can PHP Code into Word Press
    By JanDazzlingDeals in forum GoldenCAN
    Replies: 4
    Last Post: November 23rd, 2008, 03:22 PM
  4. Need A Word Processor That's Not MS Word
    By sweat in forum Midnight Cafe'
    Replies: 29
    Last Post: January 30th, 2008, 11:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •