Results 1 to 4 of 4
  1. #1
    Newbie
    Join Date
    August 26th, 2010
    Posts
    13
    Linking an ImagePath
    Is it possible to add a link to an image path?

    For example, I have an URL in my database that I reference on my detail page as: [WM-ImagePath: band_url]

    The result is an image of a band. What I want to do is then link from that image of the band to the product page.

    I'm sure someone has done this, but I can't seem to find it using the search.

    Thanks in advance.

  2. #2
    Newbie
    Join Date
    August 26th, 2010
    Posts
    13
    Okay, what I've done to move this along is to create a field in my database for both the Ad image and the Ad URL. So, I guess what I need is an HTML solution for allowing the Image to link to the URL.

    I am not trying to create another tier, but instead I want to jump from the Ad image, which is on a detail page, to an outside site page.

    What I have so far is this:
    <td>[WM-If: ad_image = empty] YOUR AD HERE [WM-Else][WM-ImagePath: ad_image] <a href="[WM-FIELD: ad_url]" target="_blank"</a> [/WM-If]</td>
    Last edited by dpdiaz; September 9th, 2010 at 04:24 AM.

  3. #3
    ABW Ambassador 2busy's Avatar
    Join Date
    January 17th, 2005
    Location
    Tropical Mountaintop
    Posts
    5,636
    Your html looks a little rusty, you would need to change that a little, to :

    <td><a href="[WM-FIELD: ad_url]" target="_blank">[WM-If: ad_image = empty] YOUR AD HERE [WM-Else][WM-ImagePath: ad_image][/WM-If]</a> </td>
    in order to have the image as a link - BUT if there is no image your anchor text for that link will be "Your Ad Here" which can't possibly relate to the URL you're linking to. A better idea might be to sort through the datafeed first to use only URLs that have images and change the [WM-If: to [WM-FIELD: ImageUrl. Most datafeeds are not ready to use "as is".

  4. #4
    Newbie
    Join Date
    August 26th, 2010
    Posts
    13
    First of all, your fix to my html worked great. But, you make a very good point, unless there is a url in the field, the default ends up linking to the same page in a new window.Keeping files in a separate folder sounds like more hassle than I want to get in to. So, I am still left with a dilemma of how to make it work. It seems like a design problem that I will still need to keep thinking on. Thanks so much for your help.

  5. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. WM-ImagePath noLink glitch
    By PhilA in forum WebMerge (Fourthworld.com)
    Replies: 4
    Last Post: December 7th, 2010, 09:30 AM
  2. Resizing an image with WM-ImagePath tag
    By billbam in forum WebMerge (Fourthworld.com)
    Replies: 1
    Last Post: June 11th, 2004, 08:26 PM
  3. Product linking when there is NO product linking offered..need help.
    By GrainFarmer in forum Google Affiliate Network - GAN
    Replies: 4
    Last Post: December 6th, 2002, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •