Results 1 to 6 of 6
  1. #1
    Newbie
    Join Date
    October 5th, 2005
    Posts
    32
    Coupon feed broken?
    I noticed today a few weeks ago that my linkshare coupon feed script was not pulling the coupons. Upon closer inspection today, the feed returned is blank. The interface says I am approved for the feed and I even tried updating my token, but it still returns no coupons. Is anyone successfully using the coupon feed web service right now? I just want to figure out if its something with my account or if the whole service is broken. The Linkshare CouponSnap page also returns no coupons with my api token.

  2. #2
    ABW Ambassador LinkShare Moderator's Avatar
    Join Date
    January 18th, 2005
    Posts
    1,316
    Hi phreak$how,

    We recently noticed this as well, we are working on trying to fix the issue. The coupon feed doesn't work when you don't have any parameters or if you exclusively use the '&network=' parameter. The feed does work if you have other parameters or multiple parameters including the '&network='.

    Let me know if you have any other questions.

    --Ranae

  3. #3
    Newbie
    Join Date
    October 5th, 2005
    Posts
    32
    Thanks for the reply. I have been talking to your team over email and what I am seeing is that the promotiontype is where the error is occurring, specifically promotiontype #11. If I include that promotion type in the URL, I get an empty set and if I exclude it, I get the correct response with coupons. Since I was using the URL without the promotiontype, it was trying to include all promotiontypes (including #11) and this resulted in the same empty set. The workaround for me was to include all promotiontypes in the URL except #11.

    This does not work:
    &promotiontype=1|2|3|4|5|6|7|8|9|10|11|12|14|30|31

    This works by excluding #11:
    &promotiontype=1|2|3|4|5|6|7|8|9|10|12|14|30|31

    network and category parameters work fine for me (even if I dont include them in the URL), so I think promotiontype is where the problem is.
    Last edited by phreak$how; September 21st, 2010 at 11:19 AM.

  4. #4
    ABW Ambassador LinkShare Moderator's Avatar
    Join Date
    January 18th, 2005
    Posts
    1,316
    Thanks -

    I will pass this onto our tech team as well.

    --Ranae

  5. #5
    ABW Ambassador LinkShare Moderator's Avatar
    Join Date
    January 18th, 2005
    Posts
    1,316
    phreak$how,

    I believe this issue should be fixed and you should be able to run all coupon feed queries. As far as Coupon Snap and other Bento Box tools, they should work as well unless you had changed your feed token, in which case the Bento Box tools will need to be re-installed again.

    --Ranae

  6. #6
    Member
    Join Date
    August 21st, 2010
    Posts
    81
    Wouldn't be surprised if the service has temporarily gone kaputz

  7. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Heads Up: Walgreens Feed is broken...
    By Convergence in forum Commission Junction - CJ
    Replies: 3
    Last Post: May 30th, 2013, 02:34 PM
  2. How to Check Broken Images in Data Feed
    By GreenAffMan in forum Programming / Datafeeds / Tools
    Replies: 6
    Last Post: March 4th, 2013, 04:21 AM
  3. Broken link in coupon feed
    By 2busy in forum AvantLink -AV
    Replies: 3
    Last Post: September 29th, 2010, 02:07 PM
  4. Jos A Bank - all links in the feed are broken
    By CrazyHunter in forum Google Affiliate Network - GAN
    Replies: 0
    Last Post: July 2nd, 2010, 04:19 PM
  5. Rockler feed broken?
    By crm911 in forum Cusimano.com Scripts
    Replies: 2
    Last Post: October 20th, 2008, 06:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •