Results 1 to 9 of 9
  1. #1
    Newbie
    Join Date
    October 31st, 2010
    Posts
    5
    Data Feed from Shareasale - Title problem
    Hello Everyone,

    I have successfully imported Data Feed from Shareasale CSV file. When I click on the post title, it gives me 404 error message. The subtitle and order links are working perfectly and take to the merchant website.

    Is there anything which I have done wrong here.



    Other Issue which I need help when the above is resolved

    Also I was told to put a php script in the main index page of the theme editor so that each post is linked internally to give SEO benefit. I pasted the script exactly where I was shown, but it was not working properly so i removed it.

  2. #2
    ABW Ambassador beachcom's Avatar
    Join Date
    May 11th, 2006
    Location
    Myrtle Beach SC
    Posts
    723
    Sounds like the post isn't being created. Are you using SEO and/or title name plug-ins? If it's a plug-in issue, sometimes it helps to deactivate them one at time and check that way.

  3. #3
    ABW Ambassador 2busy's Avatar
    Join Date
    January 17th, 2005
    Location
    Tropical Mountaintop
    Posts
    5,636
    If you imported the datafeed without altering it you might want to look at a copy of it to make sure it is ready for your script. Very few datafeeds are ready to use as-is.

  4. #4
    Newbie
    Join Date
    October 31st, 2010
    Posts
    5
    Quote Originally Posted by 2busy View Post
    If you imported the datafeed without altering it you might want to look at a copy of it to make sure it is ready for your script. Very few datafeeds are ready to use as-is.
    Thanks for your reply. The other affiliate links are working fine, it is only when I click the title link it gives error.

    If you can check
    removed

    and click on any title
    Last edited by 2busy; October 31st, 2010 at 09:21 AM. Reason: Sorry, but links are not permitted here, please check the rules

  5. #5
    ABW Ambassador 2busy's Avatar
    Join Date
    January 17th, 2005
    Location
    Tropical Mountaintop
    Posts
    5,636
    The problem you are having sounds like something in your datafeed is not what your script is looking for. That's why I suggested that you take a look at the datafeed you are using to be sure that all fields are what they should be to function with your script. If you bought the script you are using, or if you are using a plugin you might look for script support from the supplier. It is very seldom that any random script and datafeed combination will work properly "out of the box".

  6. #6
    Full Member iolaire's Avatar
    Join Date
    October 3rd, 2006
    Location
    Arlington, VA
    Posts
    229
    That sounds to me like your perma links to the posts are not working? Probably something relating to .htaccess

  7. #7
    ABW Ambassador writerguy's Avatar
    Join Date
    January 17th, 2005
    Location
    Springfield, Missouri, USA
    Posts
    3,248
    I just read this thread through for the third time. It would have been VERY helpful, faakhatri, if you had mentioned from the start that you were using the datafeed on a WordPress site.

    You are, aren't you? I assume from references to posts and permalinks that you are, but you never really said so. Or don't you realize that the vast majority of people who use datafeeds do so with php and/or html files, not WordPress.

    Anyway, something about your import setup is not creating a clickable link from the SAS Product Name field. What plugin are you using -- or are you using a php script you created yourself in your datafeed import process?
    Generate more fake news.

  8. #8
    Newbie
    Join Date
    October 31st, 2010
    Posts
    5
    Title Problem in Wordpress
    Quote Originally Posted by writerguy View Post
    I just read this thread through for the third time. It would have been VERY helpful, faakhatri, if you had mentioned from the start that you were using the datafeed on a WordPress site.

    You are, aren't you? I assume from references to posts and permalinks that you are, but you never really said so. Or don't you realize that the vast majority of people who use datafeeds do so with php and/or html files, not WordPress.

    Anyway, something about your import setup is not creating a clickable link from the SAS Product Name field. What plugin are you using -- or are you using a php script you created yourself in your datafeed import process?
    Hello writerguy

    Thank you for your reply and my apologies for not making it clear. Yes you are right, I am using wordpress, I am using a PHP script to convert CSV into XML and also I am using feedwordpress (WP Plugin) to syndicate the rss feed.

    When I click the Post Title earlier it was giving 404 error. Hostgator support rectified it (as pointed above by iolaire) and now it goes to the domain index page, which is not what I want. I want the click on post title to show a single post/page for that item.

    I also have a script for that, but there seems to be some error in that script. As you can tell I am no tech guy and I have no idea what is the problem in that script.

    Thanks
    Last edited by BurgerBoy; October 31st, 2010 at 06:33 PM. Reason: Removed Link - Check The Rules

  9. #9
    Full Member iolaire's Avatar
    Join Date
    October 3rd, 2006
    Location
    Arlington, VA
    Posts
    229
    This still sounds htaccess related, hostgator probably did a quick fix, its more than likely up to you to get your wordpress install working how you like.

    Mapping of a post title to a post is not really datafeed related but rather a wordpress config/.htaccess issue. Start over at the wordpress codex: Using Permalinks WordPress Codex
    the hostgator site doesn't have much useful info:
    .htaccess guidance HostGator.com Support Portal
    but this one might be better
    Hostgator .htaccess support

  10. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Best Data Feed Programs at Shareasale
    By goofyhumor in forum ShareASale - SAS
    Replies: 9
    Last Post: December 7th, 2007, 09:36 AM
  2. Data feed to Excel problem
    By layla in forum Google Affiliate Network - GAN
    Replies: 2
    Last Post: October 11th, 2007, 07:30 PM
  3. Problem with data feed import
    By admad1 in forum ShareASale - SAS
    Replies: 2
    Last Post: October 4th, 2005, 03:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •