I have tried to check, under "When to make new index pages", both the options "when the value of field changes" and "max number of records per page" but this last option is not executed and it keeps presenting all 1,000 records in the same index page. According to the help it should be possible to check both options. Any reason why it is not working? Is that a bug?