Results 1 to 7 of 7
  1. #1
    Newbie
    Join Date
    January 18th, 2005
    Posts
    3
    I get the error message: LWP::UserAgent is not installed

    I contacted my host and they say it IS installed...CHMOD is correct and PERL path is correct...any ideas or help is appreciated.

    Thanks.

    TE
    http://www.specialtactics.com
    USAF Pararescue

  2. #2
    ABW Ambassador cusimano's Avatar
    Join Date
    January 18th, 2005
    Location
    Toronto, Canada
    Posts
    1,369
    Download a fresh copy of the amazon.pl XML .zip file at:
    http://www.cusimano.com/scripts/amaz.../amazonxml.zip

    Unpack it and then upload the amazon.pl file using ASCII mode and set the file permissions.

    If that doesn't work, send your email address to me in a Private Topic or via the Support form.

    Yours truly,
    Cusimano.Com Corporation
    per: David Cusimano

  3. #3
    ABW Ambassador
    Join Date
    January 18th, 2005
    Posts
    532
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by TE:
    I get the error message: LWP::UserAgent is not installed

    I contacted my host and they say it IS installed...CHMOD is correct and PERL path is correct...any ideas or help is appreciated.

    Thanks.

    TE
    http://www.specialtactics.com
    USAF Pararescue<HR></BLOCKQUOTE>

    ...also don't rule out that there is a configuration issue with your hosts server(s). I have to host the amazon.pl script on a different server than my sites are on becuase I can't get ANY scripts that require PERL modules to work on my 'primary' host despite the fact that all modules are installed and "working". It took months for my host to admit that there are unresolved issues with the PERL modules.

    -------
    Stanley
    ...now accepting link exchange partners at -
    <UL TYPE=SQUARE><LI>http://www.celebrityphotoclassifieds.com<LI>http://www.collectorplateclassifieds.com<LI>http://www.toyswapper.com[/list]

  4. #4
    Newbie
    Join Date
    January 18th, 2005
    Posts
    3
    Stanley,

    Thanks...I just tried amazon.pl on an old free hypermart site of mine and yes, it worked like a charm...very interesting.

    David C...do you still need my email? I guess my real question is if it works on the hypermart server, but not my primary is there hope? Also...I use UBB.classic with no problems...and a couple other PERL scripts...not sure why this one won't work (except for the obvious LWP issue).

    TE
    http://www.specialtactics.com
    USAF Pararescue

  5. #5
    ABW Ambassador cusimano's Avatar
    Join Date
    January 18th, 2005
    Location
    Toronto, Canada
    Posts
    1,369
    I don't know if those other scripts you mention using LWP or not.

    Try http://www.c3scripts.com/test/ and see what it reports.

    Yours truly,
    Cusimano.Com Corporation
    per: David Cusimano

  6. #6
    Newbie
    Join Date
    January 18th, 2005
    Posts
    3
    Thanks David, here is what it reported:

    test.pl v2.11.27
    Perl v5.008
    CGI::Carp -- installed
    Compress::Zlib -- not installed
    LWP -- not installed
    LWP::Simple -- not installed
    @INC =
    /usr/local/lib/perl5/5.8.0/i386-freebsd
    /usr/local/lib/perl5/5.8.0
    /usr/local/lib/perl5/site_perl/5.8.0/i386-freebsd
    /usr/local/lib/perl5/site_perl/5.8.0
    /usr/local/lib/perl5/site_perl
    .

    Looks like its not installed. I'll go back to my host and ask them whats up. Thanks very much for your help.

    TE
    http://www.specialtactics.com
    USAF Pararescue

  7. #7
    ABW Ambassador
    Join Date
    January 18th, 2005
    Posts
    532
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by TE:
    Stanley,

    Thanks...I just tried amazon.pl on an old free hypermart site of mine and yes, it worked like a charm...very interesting.

    David C...do you still need my email? I guess my real question is if it works on the hypermart server, but not my primary is there hope? Also...I use UBB.classic with no problems...and a couple other PERL scripts...not sure why this one won't work (except for the obvious LWP issue).

    TE
    http://www.specialtactics.com
    USAF Pararescue<HR></BLOCKQUOTE>

    ...I wonder if we have the same 'primary' host

    -------
    Stanley
    ...now accepting link exchange partners at -
    <UL TYPE=SQUARE><LI>http://www.celebrityphotoclassifieds.com<LI>http://www.collectorplateclassifieds.com<LI>http://www.toyswapper.com[/list]

  8. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Do you have the alexa toolbar installed
    By ReallyBigGuy in forum Midnight Cafe'
    Replies: 31
    Last Post: November 28th, 2007, 09:07 AM
  2. SearchSpeedy.com How does it get installed
    By Chris - AMWSO in forum Suspicious Activity!
    Replies: 13
    Last Post: April 13th, 2004, 02:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •