Results 1 to 3 of 3
  1. #1
    Full Member c4's Avatar
    Join Date
    January 18th, 2005
    Posts
    488
    One of my clients has a strange problem - his server processes all .pl files normally but returns an 500 Internal server error when trying to open a .cgi file (when I rename the same .cgi file to .pl it WORKS!)

    I told him to contact his server admin and he said everything is supposed to be setup correctly. Now I'm asking you is there a way I can make server process .cgi same as .pl without having to bother that (s*****/lazy) admin? Any way with .htaccess or ...?

    Thanks in advance!



    YOURsoft - worlds 1st dealware scripts!
    NEW - Join YOURsoft "affiliate program for affiliate software"!

  2. #2
    ABW Ambassador sjangro's Avatar
    Join Date
    January 18th, 2005
    Location
    Boston
    Posts
    1,529
    You can try putting this in the .htaccess file:

    AddHandler cgi-script .cgi


    you may need this too:

    Options +ExecCGI

    but probably not since you can run .pl files.

    --scott

    --
    Scott Jangro
    sjangro@befree.com

  3. #3
    Full Member c4's Avatar
    Join Date
    January 18th, 2005
    Posts
    488
    Thanks, got it working [img]/infopop/emoticons/icon_smile.gif[/img]



    YOURsoft - worlds 1st dealware scripts!
    NEW - Join YOURsoft "affiliate program for affiliate software"!

  4. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Domain issue since server change - cgi-sys/defaultwebpage.cgi
    By mobilebadboy in forum Domains & Hosting
    Replies: 6
    Last Post: July 31st, 2011, 10:47 PM
  2. What are CGI files?
    By ameerulislam10 in forum Programming / Datafeeds / Tools
    Replies: 2
    Last Post: April 19th, 2011, 12:42 PM
  3. HELP! Can't upload any files to my server!
    By Ron Bechdolt in forum Midnight Cafe'
    Replies: 6
    Last Post: December 30th, 2003, 06:46 PM
  4. Server Side Include Files
    By frankodelic in forum Search Engine Optimization
    Replies: 6
    Last Post: February 14th, 2003, 12:49 AM
  5. Calling CGI on another server with SSI?
    By c4 in forum Programming / Datafeeds / Tools
    Replies: 6
    Last Post: July 26th, 2002, 06:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •