Results 1 to 6 of 6
  1. #1
    Newbie
    Join Date
    January 18th, 2005
    Posts
    9
    [WM-If: Field: Manufacturer_Name = NEC]
    [WM-Record]
    [WM-FIELD: Name]
    [WM-FIELD: Code nolink]
    [/WM-Record]
    [/WM-If]

    Assuming that my database has a column called Manufacturer Name and a record called NEC would this work? Cause I'm getting some wierd results. I use another manufacturer called Hitachi with this same code and it works just fine. When I try the NEC code it displays nothing.


    Shane

  2. #2
    Full Member
    Join Date
    January 18th, 2005
    Posts
    413
    If it works with Hitachi but not NEC, then perhaps there is something wrong with the way "NEC" appears in the database, perhaps an extra space before or after "NEC"?

    Have a Creative Day!
    FRANK, Baertracks
    Be More Creative

  3. #3
    Newbie
    Join Date
    January 18th, 2005
    Posts
    9
    Hi Baertracks

    Lets assume the data is correct, without spaces. The If statement itself looks correct, right?

  4. #4
    Member MarkJH's Avatar
    Join Date
    January 18th, 2005
    Posts
    68
    Should there be a colon after the WM-If? The definition page for WM-If in the WebMerge help files sometimes shows a colon after the WM-If, sometimes not.

    Of course, seeing as when you replace NEC with Hitachi it works, it probably isn't that!

    What are the weird results?

  5. #5
    Full Member
    Join Date
    January 18th, 2005
    Posts
    413
    Yes, the If statement looks correct.

    I tested it on a sample feed and it works fine for both NEC and Hitachi.

    Have a Creative Day!
    FRANK, Baertracks
    Be More Creative

  6. #6
    Newbie
    Join Date
    January 18th, 2005
    Posts
    9
    I found my problem, It's working great now.

    The IF statement needs to be inside the Record tags.

    Shane

  7. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Valid tracking code?
    By Chocolate_Chicken in forum Commission Junction - CJ
    Replies: 12
    Last Post: January 30th, 2006, 09:33 PM
  2. Does this seem valid?
    By hilisa in forum Commission Junction - CJ
    Replies: 1
    Last Post: February 12th, 2005, 08:15 AM
  3. Valid code too much to ask?
    By aroach in forum Rakuten LinkShare - LS
    Replies: 1
    Last Post: June 26th, 2003, 04:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •