Results 1 to 10 of 10
  1. #1
    Full Member
    Join Date
    January 18th, 2005
    Posts
    390
    I'm having problems getting WebMerge to write the urls correctly on my detail pages. I'm guessing it's a fairly easy problem to solve, though I can't figure out how.

    Here's the code in my template:
    <a href="[WM-Field: ProductURL]">Click Here</a>
    to purchase the [WM-Field: ProductName].

    And here's the code WebMerge is generating:
    <a href="<a href="http://www.productlink.htm">http://www.productlink.htm</a>">Click Here</a> to purchase the Brand X gold package.

    What want to see is:
    Click Here to purchase the Brand X gold package.

    If somebody could tell me what I need to do to fix the code on my detail page template, I would be very appreciative.

    Thanks!

  2. #2
    More Cheesier Than Ever Cheesehead's Avatar
    Join Date
    January 18th, 2005
    Location
    Land of The NFL Champs!
    Posts
    2,942
    It appears that you have <a href=" in your data field, when what you want is only the URL. If this is true, you could modify the data field entries with a find and replace.
    This World is Not My Home
    We're gonna go inside, we're gonna go outside, inside and outside. . . And then we're gonna go go go and we're not gonna stop til we get across that goalline! Quotes from the movie Rudy, 1993

  3. #3
    Action Jackson - King of the World
    Join Date
    January 18th, 2005
    Posts
    2,201
    Try [WM-Field: ProductURL]Click Here</a>

  4. #4
    Full Member
    Join Date
    January 18th, 2005
    Posts
    390
    Just to make sure that we are in the same page, you are suggesting:

    <a href=[WM-Field: ProductURL]>Click Here</a>

    instead of

    <a href="[WM-Field: ProductURL]">Click Here</a>

    Correct?

  5. #5
    Full Member
    Join Date
    January 18th, 2005
    Posts
    413
    The problem is the format of "ProductURL" in your datafeed. Does that field include/begin with the string <a href=" ?

    If so, then you do not need to include <a href=" in your WM tag. Try [WM-Field: ProductURL]Click Here</a> as suggested by Jackson992.

    If that does not fix your problem, then please post an example of "ProductURL" from your datafeed.

  6. #6
    Full Member
    Join Date
    January 18th, 2005
    Posts
    390

  7. #7
    Resident Genius and Staunch Capitalist Leader's Avatar
    Join Date
    January 18th, 2005
    Location
    Florida
    Posts
    12,817
    Try <a href="[WM-Field: ProductURL RAW]">Click Here</a>

    That's how I've got my detail templates and they work fine...
    There is no knowledge that is not power. ~Hemingway

  8. #8
    Affiliate Manager
    Join Date
    January 18th, 2005
    Location
    Los Angeles, California
    Posts
    1,913
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Leader:
    Try &lt;a href="[WM-Field: ProductURL _RAW_]"&gt;Click Here&lt;/a&gt;

    That's how I've got my detail templates and they work fine... <HR></BLOCKQUOTE>

    Whenever you have trouble with a WebMerge tag. the best first step if to review that tag's documentation -- from the WM Help page on the WM-Field tag:

    Using the raw attribute
    By default, WebMerge converts field data to HTML. The conversion changes all non-ASCII characters to their corresponding character entity according to the ISO 8859-1 standard. For example, the character "&lt;" becomes "&lt;". This attribute is useful if your database contains some fields whose data is already in HTML format, to prevent WebMerge from altering it for Web display. If your field already contains HTML, you can tell WebMerge not to perform this conversion by using the raw attribute.
    Richard Gaskin
    Developer of WebMerge: Publish any data feed on any site
    http://www.fourthworld.com

  9. #9
    Resident Genius and Staunch Capitalist Leader's Avatar
    Join Date
    January 18th, 2005
    Location
    Florida
    Posts
    12,817
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR> For example, the character "&lt;" becomes "&lt;". <HR></BLOCKQUOTE>



    And Infopop automatically renders the ISO codes into their equivalents. To make them show up on the board, you have to put extra spaces.

    Example: & a m p
    There is no knowledge that is not power. ~Hemingway

  10. #10
    Full Member
    Join Date
    January 18th, 2005
    Posts
    390
    Adding the "RAW" tag worked perfectly.

    Thanks for the help!

    Now comes the fun part of beautifying the formatting and switching from a three to a four-tier set-up.

  11. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Working Out Webmerge-created Index and Detail Page URLs.
    By thetravelpage in forum WebMerge (Fourthworld.com)
    Replies: 6
    Last Post: September 7th, 2010, 05:43 PM
  2. Dynamic URLs vs. static URLs
    By Georgie Peri in forum Midnight Cafe'
    Replies: 9
    Last Post: January 30th, 2009, 10:39 PM
  3. Affiliate URLs Vs. Merchant URLs
    By MyDayRegistry in forum Midnight Cafe'
    Replies: 2
    Last Post: March 12th, 2008, 12:25 AM
  4. WebMerge not processing subsequent setting files correctly...
    By justanotherguy in forum WebMerge (Fourthworld.com)
    Replies: 2
    Last Post: September 17th, 2007, 03:09 PM
  5. cj.com not open correctly
    By indianaff in forum Commission Junction - CJ
    Replies: 2
    Last Post: November 30th, 2006, 10:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •