Results 1 to 16 of 16
  1. #1
    Full Member
    Join Date
    January 18th, 2005
    Posts
    390
    Last night I tried exanding from a 3-tier to a four tiered set-up and could not get it to work right. I've looked at both Frank's and Fred's tutorials, but am unsure about setting up the Tier 2 page.

    Here's breifly how I have the data fields and the pages set up. I'll use cookware as an example since its easy to understand.

    Tier 1 - MainCat Field (e.g. pans, pots, utensils).
    Tier 2 - Category2 Field (e.g. Pots-Non-Stick, Pans-Stainless-Steel)
    Tier 3 - Product2 Field (e.g. Caphalon-3-Quart-Nonstick-Pan)
    Detail Page - Product info and click to buy link

    Sub-directory set-up is currently:
    store (Tier 1 page)/category (Tier 2 pages)/product (detail pages).

    I can get Tier 1 to connect to Tier 2 without any problems. On the four tier system, I can't get Tier 2 to correctly link to a Tier 3 site that links to the product detail pages. The problem is specifically with Tier 2, because my three tier set-up works great.

    Do I need to add another subdirectory? Also, could somebody give me the correct code for the Tier 2 and Tier 3 pages?

    Thanks for the help!

  2. #2
    Full Member
    Join Date
    January 18th, 2005
    Posts
    413
    The problem is most likely in the configuration of your THREE WM settings files.

    Make sure that the "Name Based on Content of Field" are correctly matching between WM settings files. They should look something like the following:

    WM setting file 1:
    Index Pages: Make only one index file
    Detail Pages: Name based on contents of field MainCat

    WM setting file 2:
    Index Pages: Name based on contents of field MainCat
    Detail Pages: Name based on contents of field Category2

    WM setting file 3:
    Index Pages: Name based on contents of field Category2
    Detail Pages: Name based on contents of field Product ID

  3. #3
    Full Member
    Join Date
    January 18th, 2005
    Posts
    390
    I appreciate your help.

    Follow-up questions.

    Directory structure is:
    store(tier 1 index)>category>product

    Should I have the detail pages created by WM Setting 1 in "category" and the detail pages created from Setting 2 in "product"?

    If I do this, will Setting 2 and Setting 3 write over the similarly named files from Setting 1 and Setting 2?

    As far as templates, do I use the exact same templates for Setting 1 detail and Setting 2 Index? How about Setting 2 detail and Setting 3 Index?

    Thanks.

  4. #4
    Full Member
    Join Date
    January 18th, 2005
    Posts
    413
    The detail templat is the same in all three WM settings files and ALWAYS linked to from the "Detail Pages" tab.

    Are you trying to create the website with files located in directories and subdirectories? This is an additional complication. I'd suggest that you start by creating all the files in ONE directory.

    You WANT WM to overwrite some of the files created by the previous WM settings run. It takes a while to wrap your brain around how multiple WM settings files work. Here is the gist of it:

    A four-tier website requires three WebMerge setting files. Each setting file creates ONE PAIR of elements, i.e. two levels of a website.

    The first WM settings file creates Index.html and TEMPORARY placeholder files/names for the Category level.

    The second WM settings file writes over those temporary category files and creates the final Category levels files. It also creates TEMPORARY files/names for the SubCategory level.

    The third WM settings file writes over those temporary subcategory files and creates the FINAL Subcategory levels files. It also ceates the FINAL product files.

    I hope this helps. Keep experimenting with different settings and you will eventually get the hang of it.

  5. #5
    Full Member
    Join Date
    January 18th, 2005
    Posts
    390
    Thanks.

    I think I have it, but will try tonight and see what happens.

  6. #6
    Full Member
    Join Date
    January 18th, 2005
    Posts
    390
    Frank,

    Thank you so much. Your instructions definitely worked, except for a few minor glitches on my end, which were easy to fix (e.g getting files in the right directory).

    If we ever run into each other, I'll buy you coffee, beer, or a meal.

  7. #7
    Action Jackson - King of the World
    Join Date
    January 18th, 2005
    Posts
    2,201
    Does anyone have AIM or MSN? For some reason I'm only getting a few products listed in a category instead of all of them

  8. #8
    Full Member
    Join Date
    January 18th, 2005
    Posts
    413
    Jack;

    Could you describe in a bit more detail the problem that you are encountering?

    You can also PM me with details if you prefer.

  9. #9
    Action Jackson - King of the World
    Join Date
    January 18th, 2005
    Posts
    2,201
    Hi Frank:

    I have since come to the conclusion that it's something in the feed but I have no idea what.

    The url is http://shopping-to-go.com/funtocollect/index.shtml

    Note that Baby Bedding only shows 2 products while Zelda lists several. I know there are more than 2 products in the feed for baby bedding.

  10. #10
    Full Member
    Join Date
    January 18th, 2005
    Posts
    413
    Jack;

    How many WM settings did you run - two or three?

    Your result looks like you only used two WM settings files (or have a misconfigured WM setting file). The Category index link is going directly to a detailed page rather than to a subcategory page that displays the individual products.

    Check your three settings files to make sure that they are configured like to ones in my tutorial.

    Also check that the datafeed is sorted correctly by Category and Subcategory. That might also be part of your problem (which would explain why you only see two items when you click on "Beddings".)

  11. #11
    Action Jackson - King of the World
    Join Date
    January 18th, 2005
    Posts
    2,201
    Hi Frank:

    I only use two runs on webmerge since I'm not using sub categories. I'm a little confused by your post as I see the index page going to the cats page then to the details page. But there's only 2 products listed on the cats page.

    Here is my current run:

    1st time:

    index template, one index page
    details template, sort by Category

    2nd time:

    subcategory template, sort by Category
    details template, sort by SKU

  12. #12
    Full Member
    Join Date
    January 18th, 2005
    Posts
    413
    If you are not using subcategories, then you should end up with 640 products listed on the category page for "Baby Bedding and Accessories" (assuming you are using the full database).

    There is only one sort option per WM setting file. In your case it should be set to sort by Category. Do not sort by SKU.

    Your two WM settings files should be set as follows

    WM1
    Index Page: Make only one index page
    Detail Page: Name based on content of field CATEGORY

    WM2
    Index Page: Name based on content of field CATEGORY
    Detail Page: Name based on content of field SKU

    Try the above, and see if that helps.

  13. #13
    Action Jackson - King of the World
    Join Date
    January 18th, 2005
    Posts
    2,201
    Hi Frank:

    I am confused. Isn't that what I just posted that I do LOL

  14. #14
    Full Member
    Join Date
    January 18th, 2005
    Posts
    413
    Jack;

    Your posting just referred to sorting. I am thinking that the issue may be a mismatch between the two WM settings files.

    It is important that the WM1 index detail page tab and the WM2 index page tab refer to the same category for the "Name based on content of field", i.e. CATEGORY.

    If you really get stuck, you can email me a copy of your WM settings files and templates. I can probably take a quick look and tell you where the problem is.

  15. #15
    Action Jackson - King of the World
    Join Date
    January 18th, 2005
    Posts
    2,201
    Hi Frank:

    I can send you my templates.

    I'm not sure what a settings file is as I set them manually for each run of webmerge

  16. #16
    Full Member
    Join Date
    January 18th, 2005
    Posts
    413
    I suspect that the problem lies with the WM settings files. You should have two of them configured and saved.

    Try creating these files following the settings shown at http://www.creativenutsandbolts.com/...%20Website.htm

    Or, begin with WM settings files that you can download at http://www.creativenutsandbolts.com/webmerge/

  17. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. 3-Tier Site - Subcategory Listing Problem
    By kbrock in forum WebMerge (Fourthworld.com)
    Replies: 7
    Last Post: January 16th, 2007, 03:42 PM
  2. Problems making 4 Tier Site
    By kdenn in forum WebMerge (Fourthworld.com)
    Replies: 8
    Last Post: September 27th, 2005, 03:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •