Results 1 to 21 of 21
  1. #1
    Full Member c4's Avatar
    Join Date
    January 18th, 2005
    Posts
    488
    Ok, here's the prob:

    I started learning CGI, went through some lessons and decided to install and try a (pre-written) script.

    I grabbed the script, uploaded it on the server, used SSI on a page to call it and I got this lovely message: [an error occurred while processing this directive]

    Ok, I said, I made an error, let's try again. I was again wormed by the lovely "[an error occurred while processing this directive]" message.

    Hmmm, what went wrong? Let's try this! ... [an error occurred while processing this directive] !?

    This? ... [an error occurred while processing this directive]
    This? ... [an error occurred while processing this directive]
    This?! ... [an error occurred while processing this directive]
    This?!!! ... [an error occurred while processing this directive]
    ...
    ...
    ...
    THIS????!!!!???? ... [an error occurred while processing this directive]

    !@*&%GRR!**#/~§!

    As You can see, I just CAN'T get the script up and running! Now, all desperate, I'm asking You ('old CGI masters') to help me with this!

    I would be more than happy if one of You could take few minutes of his time, go to 'my' server and get the script running! I know this is not the way to be done, but still ... To show You how desperate I am I'm giving You my User name and Password to access server and all necessary You need. I'd like that one of You makes this script (which wasn't wrote by me btw) working so I can see, where I went wrong and learn from my mistakes.

    Here goes:

    I'm on Netfirms.

    User name = c4n
    Pass. = ****** (I KNOW I shouldn't tell you this, but I want you to see how desperate I am)
    FTP: c4n.netfirms.com
    URL: http://c4n.netfirms.com/
    Help page for CGI on Netfirms: http://www.netfirms.com/supportSearch?BROWSE=advanced

    You have the ORIGINAL counter.pl and Readme files uploaded (next to www & cgi-bin folders, not there where they should be!), play with them...
    Batteries not included

    ***********************

    I know I'm asking for a BIG favour, but like said, I tried everything I could think of, PLEASE, PLEASE HELP ME!


    P.s.:I will rate you ***** at A best web if ya help me [img]/infopop/emoticons/icon_biggrin.gif[/img]

    OH YES, and if You see that some other member already fixed the script so it now runs, pls forget my pass and leave it alone [img]/infopop/emoticons/icon_wink.gif[/img]

    [ 11-30-2001: Message edited by: c4 ]

  2. #2
    ABW Ambassador AWaR's Avatar
    Join Date
    January 18th, 2005
    Location
    Scotland
    Posts
    625
    I can't help you script wise, but remove your password from here.

    If someone else can help send them a pm with the password if you must...

  3. #3
    ABW Ambassador
    Join Date
    January 18th, 2005
    Location
    ÄúsTrálíå
    Posts
    1,372
    Having solved this problem a few times myself, I'd offer to help, but your page leads me to 'You are not authorized to view this page', and the ftp pass is incorrect.

    what gives?

  4. #4
    Full Member c4's Avatar
    Join Date
    January 18th, 2005
    Posts
    488
    I don't care about the pass - this server is just for testing, I have nothing else there besides count.pl and readme.

    Thanks for care anyway.

  5. #5
    Full Member c4's Avatar
    Join Date
    January 18th, 2005
    Posts
    488
    Oh, Pete - the URL doesn't work couse I haven't got anything uploaded (like said), the pass must work!

    ****** (Make sure you don't copy any spaces with the pass!)

    [ 11-30-2001: Message edited by: Haiko ]

  6. #6
    ABW Ambassador
    Join Date
    January 17th, 2005
    Posts
    2,160
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>remove your password from here<HR></BLOCKQUOTE>
    and change it NOW

    Your SSI call should look something like:
    < !--#exec cgi="/counter.pl" -->

    What does your ssi call look like.

  7. #7
    Full Member c4's Avatar
    Join Date
    January 18th, 2005
    Posts
    488
    Goffy ... about the pass - read my post before yours.

    About SSI - I'm not new to SSI, I tried various combinations, inclouding one like your suggestion.

  8. #8
    ABW Ambassador
    Join Date
    January 17th, 2005
    Posts
    2,160
    OK, i was replying when you posted that comment about the password.

    But, like Pete said, the password doesn't work.

  9. #9
    Full Member c4's Avatar
    Join Date
    January 18th, 2005
    Posts
    488
    XXXXXX DOES NOT WORK??? :confused:

    I tried it 3 times now - when Pete said and now twice and didn't have any probs (I'm disconected from FTP when I'm surfing so this shouldn't be the problem)!

    I can't belive it ...

    host: netfirms.com
    User: XXXX
    pass: XXXXXX
    Port: XX (default)

    Like said, I tried it 3 times now without a problem!

    [ 11-30-2001: Message edited by: Haiko ]

  10. #10
    ABW Ambassador
    Join Date
    January 17th, 2005
    Posts
    2,160
    OK,
    works now :confused:

    have taken copy of script.

    stand by 30 mins or so.

  11. #11
    Full Member c4's Avatar
    Join Date
    January 18th, 2005
    Posts
    488
    Great, Thanks in advance!

  12. #12
    ABW Ambassador
    Join Date
    January 17th, 2005
    Posts
    2,160
    Not so great I'm afraid [img]/infopop/emoticons/icon_frown.gif[/img]

    I can't see the problem yet.

    I'm going to try it on my own server and see if it works on that.

    I've removed all the files I used and left it how I found it.

  13. #13
    Full Member c4's Avatar
    Join Date
    January 18th, 2005
    Posts
    488
    Ok, thanks for trying!

    Pls let me know if it works on your server!

  14. #14
    ABW Ambassador
    Join Date
    January 17th, 2005
    Posts
    2,160
    I can't get it going properly. [img]/infopop/emoticons/icon_frown.gif[/img]
    Having problems writing to a data file and with file locking :confused:

    Recommend you look here for a script that works. [img]/infopop/emoticons/icon_wink.gif[/img]
    http://cgi.resourceindex.com/Program...rs/Text_Based/

  15. #15
    ABW Ambassador
    Join Date
    January 18th, 2005
    Location
    ÄúsTrálíå
    Posts
    1,372
    OK I fixed it.

    There was nothing wrong with the script.

    your perl path is: #!/usr/bin/perl (different from the script default)

    your data dir is: $data_dir = "/mnt/web_a/d01/s23/a0005gq3/cgi-bin/counter/";

    Have a look at the index.shtml file for how to access the script. exec cgi did not work (I think due to the path setup of the server)

    place this tag on each page you want counted
    < !--#include virtual="cgi-bin/counter.cgi" -->

    [edited to add:]
    have a look at the year. either Y2k non-compliant (by a long shot!) or server date is wrong or buggy script
    NOW Please edit your posts to remove the pasword

    [ 11-29-2001: Message edited by: Pete ]

  16. #16
    ABW Ambassador
    Join Date
    January 18th, 2005
    Location
    ÄúsTrálíå
    Posts
    1,372
    Just realised:

    The tag above has a space between the '<' and the '!'.. THERE SHOULD BE NO SPACE.
    It will not work with a space there.

    ALSO:
    If you try to call this from files in other sub-directories, you MIGHT need to change the tag to "/cgi-bin/counter.cgi" (ie. include a leading '/')

  17. #17
    Full Member c4's Avatar
    Join Date
    January 18th, 2005
    Posts
    488
    I don't find the words to thank you, so I'll just use the common ones: Thank You! [img]/infopop/emoticons/icon_smile.gif[/img]

    I edite my post, removed the pass.

    Thanks again!

  18. #18
    ABW Ambassador AWaR's Avatar
    Join Date
    January 18th, 2005
    Location
    Scotland
    Posts
    625
    Thank you Haiko [img]/infopop/emoticons/icon_smile.gif[/img]

    [ 11-30-2001: Message edited by: fish ]

  19. #19
    ABW Founder Haiko de Poel, Jr.'s Avatar
    Join Date
    January 18th, 2005
    Location
    New York
    Posts
    21,609
    I took it off [img]/infopop/emoticons/icon_smile.gif[/img]

    Good work Pete!<IMG src=http://www.abestweb.com/ubb/icons/icon14.gif>

    Haiko

  20. #20
    Full Member c4's Avatar
    Join Date
    January 18th, 2005
    Posts
    488
    Ups, sorry about the second post with PASS, I completely forgot about it and edited only the 1st one :rolleyes: Well, I did change my pass right after I edited ny 1st post, but thanks again.

    I'll know for the next time - send pass (if necessary) by PM, eventhough I use it only as a test server.

    Btw, I now continue my CGI school and successfully tested some more scripts thanks to You, Pete [img]/infopop/emoticons/icon_smile.gif[/img]

    Oh, Yes, and thanks to A best web Forums [img]/infopop/emoticons/icon_biggrin.gif[/img]

  21. #21
    ABW Ambassador AWaR's Avatar
    Join Date
    January 18th, 2005
    Location
    Scotland
    Posts
    625
    The reason I was telling you to remove the password is because a lot of warez site owners look for FTP space on servers for uploading their warez, without the server owner knowing it and it uses up a hell of a lot of bandwidth which would probably cost you an arm and a leg to pay for.

    It's better to be safe than sorry.

  22. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Replies: 160
    Last Post: June 7th, 2010, 10:13 PM
  2. Anybody Affected By The Recent Google Mayday Update
    By pdaden in forum Midnight Cafe'
    Replies: 1
    Last Post: June 5th, 2010, 12:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •