Results 1 to 9 of 9
  1. #1
    ABW Ambassador Doug247's Avatar
    Join Date
    January 18th, 2005
    Location
    DE USA
    Posts
    931
    Ok here is the deal...I have foxserv up and running. SSI working well, PHP scripts working ok now I am trying to use myPHPadmin to load data to a table. I click on the link 'Insert data from a textfile into table' and enter my parameters for the textfile. It is a ';' delimited files with no text qualifer. when I click go I get the following error after about 30 seconds:

    SQL-query :

    LOAD DATA LOCAL INFILE '' REPLACE INTO TABLE `tblsff` FIELDS TERMINATED BY ';'

    MySQL said:


    File '' not found (Errcode: 2)

    I have no idea how to get this fixed so I'm all ears or in this case all eyes.


    TIA,
    Doug

    Bye!

  2. #2
    ABW Ambassador sjangro's Avatar
    Join Date
    January 18th, 2005
    Location
    Boston
    Posts
    1,529
    Doug, how big is the file? Your server may be timing out on the file upload or you're bumping against the max file size limit in PHP. I think it's 2MB by default.

    The setting is upload_max_filesize in php.ini.

    --
    scott@befree.com

  3. #3
    Just Lurking
    Join Date
    January 18th, 2005
    Posts
    1,263
    I can only think of two things off the top of my head.

    1. You manually typed the filename in and made a boo-boo.
    2. The file is open and can't be read.

    ok maybe three ...

    3. MyphpAdmin/MySQL usually creates a temp file does it have permission to?

  4. #4
    Just Lurking
    Join Date
    January 18th, 2005
    Posts
    1,263
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by ScottJ:
    Doug, how big is the file? Your server may be timing out on the file upload or you're bumping against the max file size limit in PHP. I think it's 2MB by default.

    The setting is upload_max_filesize in php.ini.

    --
    scott@befree.com<HR></BLOCKQUOTE>yep, you might have something there. And you might want to change this setting too:

    max_execution_time=0

    unlimited execute time

  5. #5
    ABW Ambassador Doug247's Avatar
    Join Date
    January 18th, 2005
    Location
    DE USA
    Posts
    931
    Where is the php.ini file ???

    Bye!

  6. #6
    ABW Ambassador sjangro's Avatar
    Join Date
    January 18th, 2005
    Location
    Boston
    Posts
    1,529
    Check in /etc

    or, run this:

    find / -name "php.ini" -print

    If you find it and edit it (make a backup first) you have to restart apache.

  7. #7
    Just Lurking
    Join Date
    January 18th, 2005
    Posts
    1,263
    /WINDOWS/ on Windows98 or /WINNT/ on Windows NT

  8. #8
    ABW Ambassador
    Join Date
    January 18th, 2005
    Posts
    4,423
    What version of mysql are you running? Under one of the 3.x versions (at least for linux) they have disabled the "Load data local infile" function by default.


    You can get around it by logging into the mysql server using the command line by
    mysql --local-infile=1 -u yourusername -p

    Chet

  9. #9
    ABW Ambassador Doug247's Avatar
    Join Date
    January 18th, 2005
    Location
    DE USA
    Posts
    931
    Got it going. Changed the max upload file size from 2mb to 32mb and the time out from 30sec to 3 minutes. Now its time to learn PHP.

    Thank you very much for you help.

    Doug

    Bye!

  10. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Error 500 - Internal server error
    By TrishaLyn in forum Blogging, Mobile and Social Media
    Replies: 3
    Last Post: March 15th, 2010, 08:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •