Results 1 to 8 of 8
  1. #1
    Newbie
    Join Date
    March 11th, 2005
    Posts
    3
    Question Perplexing problem
    Let me begin by saying that I am pretty new to Webmerge and to databases. I am still a total beginner with the database language and do not write code.

    That being said, here is my problem.

    I use FileMaker Pro for my data. I have been using webmerge for almost a year, I've also been using the same templates for that time period. Just got v2.4 today - was using v2.3. I do not use the upload option in Webmerge, becaue I could never get it to work right. I use it to build the pages, then I ftp them to the site.

    Recently, some of my index pages are only "recgonizing" one line of data (like this one - it should have 50 or so entries - http://www.hartlandmachinery.com/inv...ng-Center.html) instead of the whole list it should have. Other index pages, (like this one http://www.hartlandmachinery.com/inv...--Horiz.-.html) however, are coming out just fine. The perplexing part is that they all use the same index template.

    The website these files go to is www.hartlandmachinery.com/machinery.shtml
    The templates I currently use can been seen at http://www.hartlandmachinery.com/web...kerIndex_2.htm
    http://www.hartlandmachinery.com/web...r_detail_2.htm
    Out of frusturation (and a general need to update the look of the site) I created this http://www.hartlandmachinery.com/web...kerIndex_3.htm .htm template. With this template, it will not even build the pages, all I can get is an error saying "Error processing record 1:
    (Field named in Index template not found in source data: '<font')" While I understand that it's confused by the font reference, I cannot find where this rogue tag is that's causing the confusion.

    I would really appreciate any help anyone can give me. I will also gladly send whatever files necessary to solve the problem. Remember, please dumb down the answers! THANK YOU!!!

  2. #2
    Full Member
    Join Date
    January 18th, 2005
    Posts
    390
    Quote Originally Posted by Hartland
    Let me begin by saying that I am pretty new to Webmerge and to databases. I am still a total beginner with the database language and do not write code.
    I'm not qualified to wear a pocket protector either.


    Quote Originally Posted by Hartland

    Recently, some of my index pages are only "recgonizing" one line of data (like this one - it should have 50 or so entries -
    Check how the data is being sorted both in WebMerge and Filemaker. I personally use Excel.

    I find it helpful to sort the data in Excel first and then resort in WebMerge. I don't why this works, but it does.

    If this helps, I have one datafeed that converts into an index page and four layers of subdirectories (for lack of a better word); in other words, a person doesn't see the product until after looking at four pages first. (It actually makes sense given the size of the feed).

    In this instance, I first have Excel sort three columns and then I Save As the file and resort adding in a fourth column. For example, spreadsheet one is sorted by columns A,B,C and spreadsheet two is sorted by B,C,D.

    Not sure if this will solve your problem, but it might be worth a shot.

  3. #3
    Newbie
    Join Date
    March 11th, 2005
    Posts
    3
    Sweat, thanks so much for the ideas! Problem is I can't use Excel because our entire database for our inventory is set up in FileMaker. Any other suggestions?

  4. #4
    Affiliate Manager
    Join Date
    January 18th, 2005
    Location
    Los Angeles, California
    Posts
    1,913
    Quote Originally Posted by Hartland
    Sweat, thanks so much for the ideas! Problem is I can't use Excel because our entire database for our inventory is set up in FileMaker. Any other suggestions?
    There is no need to use Excel: FileMaker has sorting options, and these can be automated with script steps within FileMaker.
    Richard Gaskin
    Developer of WebMerge: Publish any data feed on any site
    http://www.fourthworld.com

  5. #5
    Newbie
    Join Date
    March 11th, 2005
    Posts
    3
    Exclamation
    Yes, FileMaker sorts, and I sort the database before I export it and have been doing it the same way the entire time I've used the program. That doesn't appear to be the problem because all my data was showing up on the website until a month ago or so. I'm obviously doing something wrong, I just don't know what.

  6. #6
    Newbie
    Join Date
    April 5th, 2005
    Posts
    1
    I am having a very similar problem.

    Index > Other Items > Calendars > Calendar 1 or Calendar 2 or Calendar 3 ?

    The problem is ... it only is showing one calendar option (Calendar 1) . Others work just fine while this is one I found that something is wrong. I checked the feed in Excel, everything looks sorted properly and is there.

    Any ideas?

  7. #7
    Another possibility could be could be your presets on your WebMerge source page. I had a hard drive go on me and had to reinstall Webmerge. I exported sorted record out of FileMaker in a merge format. My new install of WebMerge didn't have the FileMaker Pro Merge presets when I open my old setting. This gave me only one confused record per page. Changing the presets back to FileMaker Pro Merge fixed the problem. Just a thought.

  8. #8
    Affiliate Manager
    Join Date
    January 18th, 2005
    Location
    Los Angeles, California
    Posts
    1,913
    If you find a circumstance in which WebMerge is not saving any setting and is reproducible, please send the recipe to me via email and I'll adress it promptly.
    Richard Gaskin
    Developer of WebMerge: Publish any data feed on any site
    http://www.fourthworld.com

  9. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. I Have A Problem
    By fabian.jh in forum Midnight Cafe'
    Replies: 10
    Last Post: January 31st, 2007, 03:05 PM
  2. Is This a Linkshare Problem or a Merchant Problem
    By Billy Kay in forum Rakuten LinkShare - LS
    Replies: 12
    Last Post: July 22nd, 2004, 08:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •