Results 1 to 4 of 4
  1. #1
    Newbie
    Join Date
    June 24th, 2005
    Posts
    4
    Problem with use of WM-IndexLabel
    Hi All

    I am trying desparately to get the IndexLabel function to work correctly.

    I have a .csv file with the following data (abbreviated!)

    ManufacturerID,AlphaDescUpper
    153,1
    153,A
    153,A
    153,A
    153,A
    153,A

    I am trying to produce a page which shows a list of the occurance of the field "AlphaDescUpper", such as:

    "This file contains 1, A"

    The code I am using in the template file is:


    This file contains
    [WM-Record]
    [WM-IndexLabel:AlphaDescUpper]
    [WM-Field: AlphaDescUpper],
    [/WM-IndexLabel]
    [/WM-Record]

    This results in the following:

    "This file contains 1, A, A, A, A, A,"

    I'm obviously making some very simple mistake but I can't see what. I've tried various alternatives but none of them work.

    Some help would be appreciated.

    Regards

  2. #2
    Internet Cowboy
    Join Date
    January 18th, 2005
    Posts
    4,662
    Quote Originally Posted by BobFawcett
    Hi All

    I am trying desparately to get the IndexLabel function to work correctly.

    I have a .csv file with the following data (abbreviated!)

    ManufacturerID,AlphaDescUpper
    153,1
    153,A
    153,A
    153,A
    153,A
    153,A

    I am trying to produce a page which shows a list of the occurance of the field "AlphaDescUpper", such as:

    "This file contains 1, A"

    The code I am using in the template file is:


    This file contains
    [WM-Record]
    [WM-IndexLabel:AlphaDescUpper]
    [WM-Field: AlphaDescUpper],
    [/WM-IndexLabel]
    [/WM-Record]

    This results in the following:

    "This file contains 1, A, A, A, A, A,"

    I'm obviously making some very simple mistake but I can't see what. I've tried various alternatives but none of them work.

    Some help would be appreciated.

    Regards
    Make sure your feed is sorted by the 'AlphaDescUpper' column in ascending order.


  3. #3
    Newbie
    Join Date
    June 24th, 2005
    Posts
    4
    problem with use of WM-IndexLabel
    Hi UncleScooter

    Tried that, resulted in

    "This file contains A, A, A, A, 1," !!!

    Note I forgot to mention that although there are 5 X A in the data, the results show only 4 !

    The problem remains.

    Thanks anyway

  4. #4
    Affiliate Manager
    Join Date
    January 18th, 2005
    Location
    Los Angeles, California
    Posts
    1,913
    I got your email with the files attached, and when I sorted by the field used in the WM-IndexLabel tag I got the results you were looking for.
    Richard Gaskin
    Developer of WebMerge: Publish any data feed on any site
    http://www.fourthworld.com

  5. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Issues with [WM-IndexLabel]
    By tex@timefreedomnow.com in forum WebMerge (Fourthworld.com)
    Replies: 2
    Last Post: August 7th, 2005, 02:33 AM
  2. WM-IndexLabel repeated
    By hammo in forum WebMerge (Fourthworld.com)
    Replies: 9
    Last Post: May 9th, 2005, 03:33 AM
  3. Using [WM-IndexLabel] twice on same page
    By epicadventures in forum WebMerge (Fourthworld.com)
    Replies: 1
    Last Post: July 14th, 2004, 08:36 AM
  4. IndexLabel Tag - Useful?
    By suparman in forum WebMerge (Fourthworld.com)
    Replies: 2
    Last Post: January 11th, 2004, 09:53 PM
  5. IndexLabel tag
    By mjay in forum WebMerge (Fourthworld.com)
    Replies: 4
    Last Post: December 10th, 2003, 06:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •