Results 1 to 10 of 10
  1. #1
    Newbie
    Join Date
    October 13th, 2005
    Location
    Poland
    Posts
    14
    help needed
    Hi all
    i'm a total newbie in perl
    can anybody help me with the instalation of view.pl
    steb by step in shorts words what to do

    thanks fr yor patiance

    p.s.
    or i could use a link to some simle tutorial

  2. #2
    Member
    Join Date
    January 18th, 2005
    Location
    Australia
    Posts
    118
    Knowing Perl doesn't help with encoded scripts. You need to upload the scripts as follows (House of Nutrition example used):

    /.htacess
    /cgi-bin/dyse/view.pl
    /cgi-bin/dyse/hono/templates
    /cgi-bin/dyse/hono/hono-key.txt
    /cgi-bin/dyse/hono/make.pl
    /cgi-bin/dyse/hono/make2.pl

    The view.pl script is common to all the modules.

    The .htaccess file contents are updated as per every new module you choose to install.

  3. #3
    Newbie
    Join Date
    October 13th, 2005
    Location
    Poland
    Posts
    14
    ok
    i've managed to instal view.pl
    and i'm trying to install genericgifts

    when a ran make.pl i was told that lwp module is not installed and i have to download datafeed by myself, done that

    created data dir and uploaded datafeed.txt in it,
    in the doc there is written that running make.pl again and it should automaticly see the datafeed , but it doesn't it's showing the same messego to manualy upload datafeed...
    I'm confused don;t now what to do next...
    any help would be appreciated.
    bstrg
    luman

  4. #4
    ABW Ambassador cusimano's Avatar
    Join Date
    January 18th, 2005
    Location
    Toronto, Canada
    Posts
    1,369
    Upload the GenericGifts.com datafeed file to:
    /cgi-bin/dyse/genericgifts/data/datafeed.txt

    Then run make.pl again.

    Yours truly,
    Cusimano.Com Corporation
    per: David Cusimano

  5. #5
    Newbie
    Join Date
    October 13th, 2005
    Location
    Poland
    Posts
    14
    #============================================================
    # start:

    DySE::genericgifts v5.04.08
    (c)2005 Cusimano.Com Corporation, all rights reserved
    http://www.c3scripts.com/dyse/

    Start: Monday, October 17, 2005 09:02:44

    Perl v5.008004
    DySE make-lib.pl v5.04.07
    DySE dbm-lib.pl v5.01.23

    !!! WARNING: Internet > LWP module is not available. Datafeed will not be downloaded.

    http://www.c3scripts.com/dyse/version/view.txt --> /cgi-bin/dyse/genericgifts/view-version.txt
    i'm still getting this info , don't know what to do.
    the data dir with datafeed.txt is created...
    bstrg
    luman

  6. #6
    Newbie
    Join Date
    October 13th, 2005
    Location
    Poland
    Posts
    14
    ??
    anybody
    ??

  7. #7
    Newbie
    Join Date
    October 17th, 2005
    Posts
    3
    Smile
    Quote Originally Posted by luman
    !!! WARNING: Internet > LWP module is not available. Datafeed will not be downloaded.
    This is the root of your problem. The LibWWW-Perl module (LWP) is not loaded on your server. The script requires this perl module in order to work properly. Search for your error message on the following page for more help:

    http://c3scripts.com/dyse/docs.html#viewer-install

  8. #8
    Newbie
    Join Date
    October 13th, 2005
    Location
    Poland
    Posts
    14
    i'm sorry but your wrong, this moduleis only for auto downloading the datafeed
    Rename the datafeed file to datafeed.txt since this is the name that make.pl looks for.

    Upload the datafeed.txt datafeed file to your website and put it in the /cgi-bin/dyse/merchant/data/ directory.

    If the data directory does not exist, create it inside the /cgi-bin/dyse/merchant/ directory.

    Run make.pl and it should now see the datafeed.txt datafeed file. See the "Run DySE Merchant Module" section above. - it doesn't see the datafeed.txt which i uploaded as it was in the docs.
    what should i do ?
    make.pl stops with the same info that datafeed won't be dowloaded...

  9. #9
    Newbie
    Join Date
    October 17th, 2005
    Posts
    3
    ok, let's try again
    Quote Originally Posted by luman
    i'm sorry but your wrong, this moduleis only for auto downloading the datafeed

    what should i do ?
    make.pl stops with the same info that datafeed won't be dowloaded...
    OK, I'm sorry about that. I apparently missed some of the context above.
    I'm not really sure what to tell you at this point. It seems that the script either is looking for the file in a different place than where you put it or the script just can't read the file. Do you have the permissions set so that the script can read the file? And are you positive that the file is in the right location?

  10. #10
    ABW Ambassador cusimano's Avatar
    Join Date
    January 18th, 2005
    Location
    Toronto, Canada
    Posts
    1,369
    DySE::GenericGifts tries to fetch the latest version number of DySE::GenericGifts and DySE::view to determine if you're using the latest version. But the current DySE::GenericGifts (v5.04.08) tries to do that even if LWP (the internet access library routines) are not installed and that's why you're seeing the fatal error.

    Ask your hosting company to install LWP. If they won't do that then create the text file:

    /cgi-bin/dyse/genericgifts/view-version.txt

    with contents:

    v5.09.02

    and create text file:

    /cgi-bin/dyse/genericgifts/version.txt

    with contents:

    v5.04.08

    Note: If you try running make.pl 24 hours after you created those files, you'll have to recreate those files again since DySE looks at the timestamps of those .txt files and will attempt to fetch from the internet if they are older than 24 hours.

    Next release of DySE::GenericGifts fixes this. The make.pl of other DySE modules greater then v5.04.08 already have this fix.

    Yours truly,
    Cusimano.Com Corporation
    per: David Cusimano

  11. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. help needed please
    By tkvisions in forum Midnight Cafe'
    Replies: 3
    Last Post: February 25th, 2005, 03:46 PM
  2. Help Needed
    By Packy in forum Search Engine Optimization
    Replies: 1
    Last Post: January 16th, 2002, 10:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •