Results 1 to 6 of 6
  1. #1
    Member
    Join Date
    January 18th, 2005
    Location
    Choctaw, Oklahoma
    Posts
    114
    Unhappy Url acting like download
    I was working on my site and checking links when I found something odd. A link to a page is acting like a download link (i.e., instead of bringing up the page, it brings up a pop up that asks if you want to save or run this file). This is to a php page and it worked previously. I've made no changes that I think would have affected this. I don't even know how to make a download link!

    I also found some odd things on my pages, like the phrase THERE WAS AN ERROR PROCESSING THIS URL inside all of my h1 tags (which of course means all of my pages had this!) It almost sounds like my site was hacked. Any ideas on protection are welcome, also.

    Thoughts and ideas, anyone?

    FYI - I just found this out and have to leave for work so I won't be back until about 6 hours from now.
    Blessed Be,
    White Wolf

  2. #2
    Defender of Truth, Justice and the Affiliate Way
    Join Date
    January 18th, 2005
    Location
    The Swamp
    Posts
    7,503
    There was someone a bit back that experienced something like this. It was a security hole with their hosting company that allowed folks pages to be hacked and malicous code inserted for a trojan download. It had happened not only to their sites, but to many of the sites hosted on their server.

    You probably want to start by contacting your hosting company.

  3. #3
    Member SeanW's Avatar
    Join Date
    July 28th, 2005
    Posts
    69
    It's sending out an incorrect MIME type. Are you using PATH_INFO at all? I ran into that a few weeks ago.

    Sean

  4. #4
    Member
    Join Date
    January 18th, 2005
    Location
    Choctaw, Oklahoma
    Posts
    114
    Yeah, Kellieb, I think I'm gonna have to contact my hosting company. I've spent over two hours trying this and trying that, I'm just so aggravated.

    Sean, this is just a plain jane, vanilla text link. It is php as opposed to html. It's for a link exchange. I've checked other sites on the exchange and their links work. Also, I've changed nothing and it USED to work.

    OH WHY OH WHY does this have to happen just when I get a good roll going on writing articles? I'm stopped dead in my tracks until I can get this fixed.

    I'll try googling it, too. Thanks, guys.
    Blessed Be,
    White Wolf

  5. #5
    ABW Founder Haiko de Poel, Jr.'s Avatar
    Join Date
    January 18th, 2005
    Location
    New York
    Posts
    21,609
    Editor used? Frontpage?

    Are you coding the page relatively (ie. /images/whater.gif) or absolutely (my guess)?
    Continued Success,

    Haiko
    The secret of success is constancy of purpose ~ Disraeli

  6. #6
    Member
    Join Date
    January 18th, 2005
    Location
    Choctaw, Oklahoma
    Posts
    114
    I feel stupid
    I use dreamweaver - url is absolute.

    I found the problem. I know just enough coding to be dangerous, apparently. I modified (some time ago) my .htaccess thus:

    AddType text/html .html
    AddHandler server-parsed .htm .html .php

    I removed php and voila! It now works fine.

    Just call me Ms. Dumbass.
    Blessed Be,
    White Wolf

  7. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. EPC Download Feature - in Transaction Download Reports
    By GoColts in forum eBay Partner Network
    Replies: 1
    Last Post: April 18th, 2011, 10:11 PM
  2. Download Linkshare reports using URL
    By huagle.llc in forum Rakuten LinkShare - LS
    Replies: 0
    Last Post: April 13th, 2007, 08:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •