Results 1 to 4 of 4
  1. #1
    Newbie
    Join Date
    January 16th, 2006
    Posts
    2
    Question kimmyshop - I'm stuck..
    In trying to run make.pl, I'm getting this error:

    no database file: 'kimmyshop'. Run make.pl. No database file: /home/toonsga/public_html/cgi-bin/dyse/kimmyshop/data/data.db
    mod re-write is obviously working as is view.pl

    I've tried to manually download the kimmyshopcom.txt file and still get the same error.

    Any thoughts on what I may have missed?

    Thanks!

  2. #2
    ABW Ambassador cusimano's Avatar
    Join Date
    January 18th, 2005
    Location
    Toronto, Canada
    Posts
    1,369
    Check your .htaccess file. It is probably broken. That error is generated by view.pl so when you're trying to access make.pl, your broken .htacess is redirecting to view.pl and view.pl is generating that error since there's no database file.

    If you remove the DySE related lines from your .htaccess file and then try running make.pl, make.pl will most likely run.

    Yours truly,
    Cusimano.Com Corporation
    per: David Cusimano

  3. #3
    Newbie
    Join Date
    January 16th, 2006
    Posts
    2
    Thanks! I deleted the .htaccess file and ran make.pl and that worked...

    I'm using the .htaccess from the kimmyshop module:

    Options +FollowSymLinks

    RewriteEngine on
    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.+$ - [L]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ cgi-bin/dyse/view.pl?merch=kimmyshop&dir=&path=$1 [L]
    Any idea what needs to be *fixed* ?

    I don't know enough about .htaccess to know myself.

    Thanks again

  4. #4
    ABW Ambassador cusimano's Avatar
    Join Date
    January 18th, 2005
    Location
    Toronto, Canada
    Posts
    1,369
    The RewriteCond with the !-f at the end should have made cgi-bin URL's work. Perhaps something to do with your server.

    Try adding the following additional line after the first RewriteRule line (blank lines are ignored so you can add one if you want):

    RewriteRule ^cgi-bin/.+$ - [L]

    This line should cause any URL's that start with "cgi-bin/" to be processed by the server as usual rather than being redirected by view.pl (via the last RewriteRule line). Note: There are spaces before and after the 2nd hyphen. The ^cgi-bin/.+$ is what to match with (anything starting with cgi-bin/), the - is what to replace it with (- means don't do any replace), and the [L] is an option that says to stop at this rule if it matches (L is short for "last").

    Yours truly,
    Cusimano.Com Corporation
    per: David Cusimano

  5. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. KimmyShop is down
    By msladybug in forum ShareASale - SAS
    Replies: 1
    Last Post: December 2nd, 2007, 03:23 PM
  2. Kimmyshop tracked
    By mellie in forum Test Purchase Reports
    Replies: 0
    Last Post: July 20th, 2006, 11:22 AM
  3. Kimmyshop.com Offline
    By meleemel in forum ShareASale - SAS
    Replies: 20
    Last Post: December 22nd, 2005, 01:11 AM
  4. KimmyShop.com/KimmyShop.ca Data Feeds Updated
    By Kimmyshop in forum ShareASale - SAS
    Replies: 0
    Last Post: March 30th, 2005, 07:52 PM
  5. New KimmyShop.com Feed
    By Kimmyshop in forum ShareASale - SAS
    Replies: 12
    Last Post: October 30th, 2003, 05:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •