Results 1 to 5 of 5
  1. #1
    Full Member
    Join Date
    January 18th, 2005
    Posts
    390
    Can't Get Images to Appear in Tables
    I'm trying to create a simple page with a three column table that would simply have an thumbnail image right above the product link.

    The tables seem to be working, but I'm getting what appears to be html code errors with the images. The images are not appearing, but the hyperlink for the image is.

    Could someone check my code?

    <table>
    <tr>
    <td valign="top" align="center">

    [WM-Record cols=3][WM-IndexLabel: ImageURL RAW]
    <center><a href="http://www.domain.com/Category/Product/[WM-Field: ProductName2 nolink].htm"><img src="[WM-Field: ImageURL RAW]" width="100" border="0"></a>
    <BR>
    <a href="http://www.domain.com/Category/Product/[WM-Field: ProductName2 nolink].htm"
    title="[WM-Field: ProductName2 nolink]">[WM-Field: ProductName2Show nolink]</a>

    [/WM-IndexLabel]
    [/WM-RECORD]


    </td>
    </tr>
    </table>


    Thanks in advance.

  2. #2
    Full Member
    Join Date
    January 18th, 2005
    Posts
    390
    If I don't get a reply soon, I'm going to do something irrational, like clean my house!

    I've gone throught several messages on this board and I cannot get the $#@%!!!! code to work right. I'm sure it's an easy fix, so if somebody can get me get me the fix, I won't suffer from html withdrawal...

    I'm want to create an index page, with images, that links to a detail page. Here's the code I'm using (latest version of my completely in vain attempts at coding):

    <table>
    <tr>
    <td valign="top" align="center">

    [WM-Record cols=3][WM-IndexLabel: ProductName2]
    <center><a href="http://www.domain.com/Category/Product/[WM-Field: ProductName2 nolink].htm"><img src="[WM-ImagePath: ImageURL nolink]" width="100" height="100" ></a>
    <BR>
    <a href="http://www.domain.com/Category/Product/[WM-Field: ProductName2 nolink].htm"
    title="[WM-Field: ProductName2 nolink]">[WM-Field: ProductName2Show nolink]</a>

    [/WM-IndexLabel]
    [/WM-RECORD]


    WebMerge, in turn, completely insults me by generating a page with this code:

    <table>
    <tr>
    <td valign="top">
    <center><a href="http://www.domain.com/Category/Product/Acme_Widget.htm"><img src="<img src="http://www.domain.com/acmewidget.jpg" border="0" nolink>" width="100" height="100" ></a>
    <BR>
    <a href="http://www.netsweat.com/Category/Product/Acme_Widget.htm"
    title="Acme_Widget">Acme Widget</a>


    </td>


    Please help me before I reach for the vacuum!!!!

  3. #3
    The Eternal Optimist zimmy's Avatar
    Join Date
    January 18th, 2005
    Location
    NC
    Posts
    696
    Hope you didn't have too much time for cleaning!

    Try taking out the <img...> tag and if you want the image to be linked use something like this:

    <a href="[WM-Field: Website_URL]">[WM-ImagePath: IMAGE_URL]</a>



    ~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*

    The big shots are only the little shots who keep shooting.
    -Christopher Morley

  4. #4
    Full Member
    Join Date
    January 18th, 2005
    Posts
    390
    Too late, I've already started working on the kitchen. But, there's still time to put an end to this sinful activity!

    The code worked - YOU ARE THE MAN (unless, of course, you're a woman, but enough of these gender issues...).

    How do I add size attributes? The images are of various sizes and I'd to standardize them (e.g. 100x100).

    Gracias and merci beacoup.

  5. #5
    Affiliate Manager
    Join Date
    January 18th, 2005
    Location
    Los Angeles, California
    Posts
    1,913
    Quote Originally Posted by sweat
    How do I add size attributes? The images are of various sizes and I'd to standardize them (e.g. 100x100).
    The WM-ImagePath tag is a convenient way to display images, but it doesn't offer the full flexibility of HTML.

    In HTML, images are displayed using the IMG tag. Given that WebMerge can replace any part of a template with database info and your database contains info which are URLs to images, you can use the WM-Field tag withing your own IMG tag like this:

    <img src="[WM-Field MyImgUrl raw nolink]" height=100 width=100>
    Richard Gaskin
    Developer of WebMerge: Publish any data feed on any site
    http://www.fourthworld.com

  6. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Free images? good quality images cheap?
    By breakingtheborders in forum Blogging, Mobile and Social Media
    Replies: 0
    Last Post: November 18th, 2011, 09:47 AM
  2. Ugg Images = Copyrighted images!
    By it2shoes in forum Commission Junction - CJ
    Replies: 16
    Last Post: March 13th, 2009, 08:32 AM
  3. PHP and tables
    By dak142 in forum Programming / Datafeeds / Tools
    Replies: 4
    Last Post: June 27th, 2004, 03:34 PM
  4. Need Help With Tables & IE
    By sweat in forum Programming / Datafeeds / Tools
    Replies: 6
    Last Post: July 10th, 2003, 12:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •