Results 1 to 9 of 9
  1. #1
    Newbie
    Join Date
    September 10th, 2006
    Posts
    2
    URL file-access is disabled in the server configuration
    Hi guys,

    I downloaded the Regnow PHP Template Download Datafeed but after making the necessary adjustments, I get the following error when opening the template.php (I renamed mine):


    Warning: fopen(): URL file-access is disabled in the server configuration in /home/content/m/n/s/mnsonline/html/regnow_datafeed/fs_php/core/system.php on line 254

    Warning: fopen(http://dc1datafeed.regnow.com/Srv/ts...id=&k=&s=0&dk=): failed to open stream: no suitable wrapper could be found in /home/content/m/n/s/mnsonline/html/regnow_datafeed/fs_php/core/system.php on line 254


    Could you please advice what could be causing this error message…? Here is the direct link: www.mns-online.net/regnow_datafeed/software.php.

    MNS-Online.net

  2. #2
    ABW Ambassador Nature Boy's Avatar
    Join Date
    January 18th, 2005
    Location
    Tennessee
    Posts
    1,423
    Quote Originally Posted by mnsonline
    Warning: fopen(): URL file-access is disabled in the server configuration in /home/content/m/n/s/mnsonline/html/regnow_datafeed/fs_php/core/system.php on line 254
    Don't hold me to it, but I believe your host does not allow remote connections. In other words, contact your host and tell them what your wanting to do, and if they can set it up for you.
    Scott
    If you can't dazzle them with brilliance, then baffle them with bulls#!t
    Don't tell me that you'll do it... SHOW ME.
    Just because everyone else is drinking it is no reason for me to drink the KOOL-AID.

  3. #3
    notary sojac Herb ΤΏΤ¬'s Avatar
    Join Date
    January 18th, 2005
    Location
    Central/Western NY State
    Posts
    7,741
    and whatever you do, think it over before you enable fopen (assuming you can) as it is usually turned off for a good reason.

    there may be a workaround for you with the use of curl, but I'm not a programmer and where it worked for me for a while with a very similar problem it now doesn't and I don't understand that.

    I've posted a bit of php using curl in the GoldenCAN forum telling where I was able to get around a server problem but as I say, there seems to be a problem with it now.

  4. #4
    Full Member
    Join Date
    January 18th, 2005
    Posts
    284
    It is a security issue. I have sites at several different hosting companies and some have blocked remote file access. Curl works at one - but I don't expect that to last. I expect as time passes the majority of hosting companies will block URL file-access

    This one of the reasons I have started to use WebMerge. I'm not big enough for my own server so I am dependant upon several different host who can without notice make my dynamically feed site non-functional.

    Certainly is an impact on XML driven sites (:
    CharPaula
    Staying focused on the bottomline

  5. #5
    Moderator BurgerBoy's Avatar
    Join Date
    January 18th, 2005
    Location
    jacked by sylon www.sylonddos.weebly.com
    Posts
    9,618
    Talking
    I have one of my sites on bluehost and they allow remote datafeed connection.

    I have never had any problems with them so far.

    Vietnam Veteran 1966-1970 USASA
    ABW Forum Rules - Advertise At ABW

  6. #6
    Newbie
    Join Date
    November 10th, 2006
    Posts
    1
    I had that problem too. Here is how to fix it:

    Locate the php.ini and set allow_url_fopen to On

  7. #7
    Newbie
    Join Date
    July 17th, 2006
    Posts
    1
    Hi

    Simply upload the entire subdir - fs_php, it is required

  8. #8
    Newbie
    Join Date
    February 13th, 2008
    Posts
    1
    Just change the url from absolute to a relative path on the fopen and that should take care of that. I had this problem with getimagesize().

  9. #9
    Newbie Timewarp's Avatar
    Join Date
    July 21st, 2007
    Posts
    34
    I had the same problem at Dreamhost, you could not just "set allow_url_fopen to On" unfortunately. Their wiki shows how to do a curl version that works. Their other suggestion is to install your own version of php that has it enabled, great.

    I think local paths work too if it's a local file.

  10. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. Getting large file from remote server
    By mobilebadboy in forum Programming / Datafeeds / Tools
    Replies: 7
    Last Post: September 30th, 2007, 12:55 AM
  2. Can't access ftp server.
    By suzigeek in forum ShareASale - SAS
    Replies: 21
    Last Post: October 4th, 2005, 12:37 AM
  3. Getting Server Errors trying to Access Ad Details?
    By gettnthar in forum PartnerWeekly
    Replies: 1
    Last Post: April 5th, 2004, 08:46 PM
  4. File access solved!!!
    By Iggy in forum WebMerge (Fourthworld.com)
    Replies: 1
    Last Post: November 7th, 2003, 05:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •