Results 1 to 12 of 12
  1. #1
    Newbie
    Join Date
    January 18th, 2005
    Location
    Small town Napanee, ON. High tech High Speed Hook up though!
    Posts
    20
    Exclamation bug in ae.pl beta
    I noticied a considerable drop, (to none) sales with the script for amazon.com.
    I had them check my links on homepage and they did and said they were fine.
    I use the mod rewrite engine to format links.

    Anyhoo, I did some more tests clicking on links. I found that clicking on subcategory links did not return results to a page on my site, rather it brought up a page on amazon, with the correct catagory requested.

    I copied the link http://www.amazon.com/exec/obidos/tg...g2=AFFILIATEID

    I replaced my aff id with AFFILIATEID for this example.

    Here is the reply I got from amazon;

    The link included in the message we received in regards to your
    account was as follows:

    http://www.amazon.com/exec/obidos/tg/browse/-/565098?
    tag2=your_Associates_ID

    I have found that the link is not formatted correctly. Therefore, we
    are unable to track any activity and sales placed via this link.

    Here is the formatting of a generic link that would be formatted
    correct (providing that the correct information is inserted, as
    outlined below):

    http://www.amazon.com/dp/ASIN/ref=no..._Associates_ID

    Now I am not sure if a setting in my ini file could have returned this, I had ref=nosim turned on and page redirect turned off.

    I have uploaded an older version of ae.pl and done some testing to ensure I do not lose any more sales.
    I will also be posting this on amazon discusssion board.

  2. #2
    Newbie
    Join Date
    January 18th, 2005
    Location
    Small town Napanee, ON. High tech High Speed Hook up though!
    Posts
    20
    I am going to have to try the script without using virtual directory, as I loaded an older version of ae.pl and still got the same results

  3. #3
    Newbie
    Join Date
    February 22nd, 2007
    Posts
    4
    Thanks for the info!

    I'm very much interested in this, as I still have many of these Associate Engine links throughout my pages on two sites. The versions I'm using are ae.pl v6.08.04-beta, and ae.pl v4.05.31, which hasn't been upgraded in awhile.

    Since I have a variety of link formats on hundreds of pages, I didn't realize these weren't tracking. I'm testing some of them now. The nice thing about AE's links was the fact that the search engine spiders loved them. At one time, I had thousands of AE's links indexed on Google. In fact, I blamed Google for the loss of most of my sales last year because many of my previously indexed links had been removed from Google. However, there are still quite a few of them that are still indexed. In most cases, visitors never even saw my sites, they just searched for items on Google, clicked on the links and went directly to Amazon. I did notice that sales have been decreasing since the end of Q1 2006, however, I don't know when these links stopped tracking. What worries me most is that many of these links are still indexed on Google and other search engines, which means that a lot of free traffic is being sent to Amazon without me getting any credit.

    Amazon is not my main affiliate program, but I hate to think that the work I put into it is being lost. I hope this problem can be fixed so that we still get credit with these links. I have also emailed Amazon Associates and am waiting for a response.

    BTW - Cusimano's Associate Engine still uses ECS 3.0, which does not support a lot of the new categories at Amazon, such as Gourmet Food, Apparel, and others. This is why I have gradually changed to Amazon's link formats, and using aStores.

    Anyway, after reading your post, I did some research in Amazon's AWS section and found this post on Amazon's Web Services forum at http://developer.amazonwebservices.c...spa?annID=164:
    "ECS 3.0 Shutdown Plan - March 31, 2008"
    Part of it reads "After March 31, 2008 , we will no longer be accepting Amazon ECS 3.0 requests. The existing maintenance effort saved by shutting down Amazon ECS 3.0 will be re-invested into Amazon ECS 4.0 to allow for the introduction of more features and capabilities..."

    I'm not sure if Cusimano is going to do anything about this since he hasn't bothered to upgrade Associate Engine to ECS 4.0.

    P.S. I have also posted this on Amazon Associates discussion board.

  4. #4
    ABW Ambassador cusimano's Avatar
    Join Date
    January 18th, 2005
    Location
    Toronto, Canada
    Posts
    1,369
    Amazon.com does its own redirects. What you see on the address bar is the final URL that amazon.com redirects to. That is not the URL that AE redirects to. AE redirects to Amazon.com with your amazon associates ID.

    For example,
    YOURDOMAIN.com/amazon/type_browse/mode_565098
    (or YOURDOMAIN.com/cgi-bin/ae.pl?type=browse&mode=565098)
    redirects to:
    http://www.amazon.com/exec/obidos/redirect?path=tg/browse/-/565098&tag=YOURIDHERE

    Copy the AE URL and go to http://www.rexswain.com/httpview.html and submit the AE URL there. It will show you all the redirects that are going on. You will see that Amazon.com does two redirects itself and finally ends up at http://www.amazon.com/exec/obidos/tg/browse/-/565098?tag2=YOURIDHERE

    AE is redirecting correctly to amazon.com. The tag2= comes from Amazon.com's own redirects.

    Yours truly,
    Cusimano.Com Corporation
    per: David Cusimano

  5. #5
    Newbie
    Join Date
    February 22nd, 2007
    Posts
    4
    David,

    Thank you for your response. This is all very confusing for me. Does this mean that these links are still tracking orders correctly?

    Would you please respond to the the part in my post regarding AE not supporting the new Amazon categories, such as gourmet food, home and garden, jewelry & watches, etc. (not that new anymore), as well as what's going to happen when ECS 3.0 goes away?
    Last edited by SusanFL; February 22nd, 2007 at 01:54 PM.

  6. #6
    Newbie
    Join Date
    January 18th, 2005
    Location
    Small town Napanee, ON. High tech High Speed Hook up though!
    Posts
    20
    That is all well and fine David. I am sorry I first came out saying it was a bug. I, as a paying customer of your script with a few annual payments on top of what I originally paid you, don't care what amazon does with it.

    Your script does not work now that amazon has changed something. So either amazon has to change their re-direct or you have to come up with a fix to make the script work. If amazon is "unable to track any activity and sales placed via this link" then what good is your script? Useless.

  7. #7
    ABW Ambassador cusimano's Avatar
    Join Date
    January 18th, 2005
    Location
    Toronto, Canada
    Posts
    1,369
    If you were to link to http://www.amazon.com/exec/obidos/tg/browse/-/565098?tag2=your_Associates_ID then tracking probably would not work. But that is not what AE redirects to. AE redirects to http://www.amazon.com/exec/obidos/redirect?path=tg/browse/-/565098&tag=YOURIDHERE -- Amazon.com does two redirects itself and the final URL in Address Bar says "tag2=" but that does not mean that amazon.com didn't see and track the intial landing at amazon.com.

    Yours truly,
    Cusimano.Com Corporation
    per: David Cusimano

  8. #8
    Newbie
    Join Date
    January 18th, 2005
    Location
    Small town Napanee, ON. High tech High Speed Hook up though!
    Posts
    20
    So, what I need to ask amazon associates then does the following track my link for credit on a sale - cause they haven't recorded any other than an add to cart sale with a different script so far this year:
    http://www.evaluebuy.com/shops/type_...de_508532.html direct to
    http://www.amazon.com/exec/obidos/re...2&tag=ASSOC_ID redirects to
    http://www.amazon.com/exec/obidos/re...p;tag=ASSOC_ID redirects to
    http://www.amazon.com/gp/redirect.ht...2&tag=ASSOC_ID redirects to
    http://www.amazon.com/exec/obidos/tg...?tag2=ASSOC_ID

    The cookie is set at
    http://www.amazon.com/gp/redirect.ht...2&tag=ASSOC_ID

    So in my best estimate, that is the url that I need to confirm tracking with amazon services

  9. #9
    ABW Ambassador cusimano's Avatar
    Join Date
    January 18th, 2005
    Location
    Toronto, Canada
    Posts
    1,369
    http://www.amazon.com/exec/obidos/redirect?path=tg/browse/-/508532&tag=ASSOC_ID

    Yours truly,
    Cusimano.Com Corporation
    per: David Cusimano

  10. #10
    Newbie
    Join Date
    February 22nd, 2007
    Posts
    4
    I tested 5 of my AE links yesterday and after reviewing my Amazon Orders Report today, I discovered some bad news.

    4 out of 5 links that were clicked on showed up under Items with no orders. The 4 that were on the report all basically used Associate Engine's format for type_browse/mode AND produced results on my web site's template pages. The products listed on the page were considered direct product links, were clicked on and added to the shopping cart.

    1 link used AE's format for type_bestsellers/mode_281052, but instead of producing results on my web site, it redirected to Amazon at: http://www.amazon.com/exec/obidos/tg...g2=associateID

    I then clicked on one of the items on the page and added it to the shopping cart. It DID NOT show up on my Orders Report (Items with no orders).

    It appears that we are not given credit for links that redirect to Amazon.

    This looks like a problem that has to be resolved by both Amazon and Cusimano. There may be a lot of these links out there (search engines, especially) that we are not getting credit for.

    Please note that several other browse modes that I clicked on were also redirected to Amazon, but I have not documented them all. Is there a list of browse modes that are supported by AE? Is there a list of browse modes that are not supported?

    What can be done about this?

  11. #11
    ABW Ambassador cusimano's Avatar
    Join Date
    January 18th, 2005
    Location
    Toronto, Canada
    Posts
    1,369
    I asked Amazon about the link, and they said that it does track.

    Yours truly,
    Cusimano.Com Corporation
    per: David Cusimano

    > -----Original Message-----
    > From: Amazon.com Customer Service
    > Sent: February 23, 2007 9:19 AM
    > Subject: Your Amazon.com Associates Inquiry
    >
    >
    > Greetings from the Amazon.com Associates Program.
    >
    > I have reviewed the Associates link you provided,
    > http://www.amazon.com/exec/obidos/redirect?path=tg/browse/-
    > /565098&tag=MYIDHERE, and have found that the link is formatted
    > correctly (when you insert the correct Associate ID). We are able to
    > track activity and sales placed via this link.
    >
    > Thank you for participating in the Associates Program.
    >
    > Best regards,
    >
    > Eric
    > Amazon.com Associates Program

  12. #12
    Newbie
    Join Date
    February 22nd, 2007
    Posts
    4
    That's what Amazon keeps telling me, but after the redirect, when a product is clicked on and added to the cart, it does not show up on the orders report (items with no orders). This is crazy, are evaluebuy and I the only ones that have a problem with this?

    I will test the redirected links again tonight, but it is very strange that the links that produced results show up on the report, but the redirected links do not.

    Nevermind, I just realized that these items wouldn't show up on the orders report as direct links. I guess I have to take Amazon's word for it that the redirects are tracking.

    Would you please explain why some modes will produce results and some won't?

  13. Newsletter Signup

+ Reply to Thread

Similar Threads

  1. another bug
    By waytogo in forum Commission Junction - CJ
    Replies: 1
    Last Post: October 14th, 2005, 10:01 PM
  2. Fellow Beta-phobes, joyous day! Google Direct Deposit Out of Beta!
    By Leader in forum Search Engine Optimization
    Replies: 6
    Last Post: October 1st, 2005, 01:36 PM
  3. Using beta version v5.03.31-beta
    By evaluebuy in forum Cusimano.com Scripts
    Replies: 3
    Last Post: April 21st, 2005, 08:17 PM
  4. bug!!!
    By kcd in forum Rakuten LinkShare - LS
    Replies: 1
    Last Post: June 30th, 2003, 09:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •